Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Recommended Posts

I have a 2005 Boxster S and have been having an intermittent problem with my Low Oil Pressure light. I first noticed it when at the track last month. after about 15 minutes of driving the warning light would flash, it didn't stay on. It took me a couple times just to read it because it flashed so fast. I took it to the shop and they replaced the Oil Sending Unit and said the pressure was at 80 psi at 5K RPMs which was in spec. This weekend I drove 150 miles and it flashed a couple times at the end of the trip. It didn't come on when I made the return trip. Any ideas?

Link to post
Share on other sites
    You can remove these ads by becoming a Contributing Member.

  • 1 year later...

I'm struggling with this same issue on my 2006 Cayman S - except mine stays on all the time but a mechanical gauge shows I have plenty of pressure. Replacing sensor did not help and the wiring from the sensor to the DME (Pin D24) is perfect.

Can anyone confirm that the idiot light sender in the 987 shows no resistance with the engine off and infinite resistance with the engine running. From what I can tell, that is correct behavior.

Edited by CBRacerX
Link to post
Share on other sites
  • 11 months later...

I bought a Boxster S 2003 1 month ago that has not been driven for the past 1 year. However the dealer told me right before i took off with my car that he changed the oil and its ready to be driven until 5000KM ... after just 800 km i decided to change the oil myself to have a peace of mind, i did and by using Mobil1 0w40.

I noticed that the Oil Measurement started draining after few days, dropping to almost in the middle range in the dashboard... So when i was driving today for almost 30 mins it flashed for me in red "Low oil pressure" afterwards it quickly disappeared ...

i hope it isnt something serious though

Link to post
Share on other sites
  • Moderators

I bought a Boxster S 2003 1 month ago that has not been driven for the past 1 year. However the dealer told me right before i took off with my car that he changed the oil and its ready to be driven until 5000KM ... after just 800 km i decided to change the oil myself to have a peace of mind, i did and by using Mobil1 0w40.

I noticed that the Oil Measurement started draining after few days, dropping to almost in the middle range in the dashboard... So when i was driving today for almost 30 mins it flashed for me in red "Low oil pressure" afterwards it quickly disappeared ...

i hope it isnt something serious though

 

I would at least have the car looked at; it should not have a dropping oil level, much less a flashing oil light.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.