Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)
Sign in to follow this  
linorod

radio station won't stay tuned

Recommended Posts

I have a 2008 911 turbo with the factory Nav radio. all radio stations seem fine except one. Whenever I tune into 97.9, it only stays set for a few seconds, then the radio changes to 105.1, which I don't even listen to. I've tried saving it in different memory locations, and just tuning to it directly, and no matter what I do it only stays set a few seconds, then it switches to weather and news on 105. I even tried resetting the radio to factory defaults, but same problem persists. I see a "button" for traffic, but having that selected or de-selected has no effect. Please responds if you've run into this problem

Share this post


Link to post
Share on other sites

I kind of have a similar problem. When listening to my cd, it tunes to an fm station. I am thinking my iPhone is interfering with the PCM? I am going to try without my phone.

Share this post


Link to post
Share on other sites

I would take it to the dealer and have them look at it. It may just be a setting. Is your car under warranty?

I have had 2 PCM's fail on my 07 TT. (both under CPO warranty) If the car is under warranty take it to the dealer.. They will just replace the whole unit. That will fix your radio problem.. :king:

Share this post


Link to post
Share on other sites

Nope, I am the warranty. Just hit 50k a month ago and it's my first glitch. Someone told me it could be a radio setting.

Share this post


Link to post
Share on other sites

Ran my diagnostics with Durametric and found no errors in multimedia interface PCM this morning. But i did find a setting in the PCM " Traffic Button". From what I understand if it is enabled, then whatever is set in "Audio Set", if a Traffic annoncement is made it will switch to the frequency set in "PTY filter" I set it all to OFF. This seems to have fixed my problem. Broadcasts alerts (some of which are timed, others are urgent). When the traffic feed comes in, the audio system will automatically switch to that feed instead of the radio station you are listening to Further reading is in PCM 2.1 pages 23 thru 39. I guess if you reset your PCM which I did, it defaults to certain settings and one of them enables that Traffic crap. I would be listening to my iphone or cd and bam 87.5 would come in. It would occur a couple of times while I drove. Since 87.5 is the first frequency on the list, that would pop in.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.