Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Recommended Posts

Just read an article in a recent issue of Excellence and in the tech session they suggested as preventative maintenance, to consider replacing the water pump every four years or 50,000 miles. Never heard this before and was wondering if anyone has done this or, an opinion on their recommendation.

Link to post
Share on other sites
    You can remove these ads by becoming a Contributing Member.

  • Moderators

The article has merit as the plastic impeller blades in the pumps tend to degrade and break up over time, spreading plastic bits into the cooling system that create local hot spots long before the pump itself starts to crap out.

Link to post
Share on other sites

I had my indy shop proactively replaced the waterpump (and coolant, thermostat and serpt belt) on my 2006 987S this fall, prior to winter hibernation. Mileage was right about 50,000. Cheap insurance. My waterpump looked excellent. Total for all this work, including an oil change (labor only, I supply my own oil.....Joe Gibbs DT40 5W40) was about $1,000. Parts were purchased from Sunset.

Link to post
Share on other sites

Two weeks ago, I replaced my water pump and thermostat as a preventative measure on my 2007 C2 with 70K miles. Even with the DIY instructions from a few of the forums, it took much longer than I expected (~10 hours). One of the seven screws on the WP is very difficult to access even with a variety of sockets, universals, and wobble extensions. And one of the four screws on the t-stat is even harder to reach, which could have been easier if I had removed the adjacent exhaust header but from past experience that can open a worse can of worms (exhaust manifold bolts break quite easily). I have a full lift, so I can only imagine that the project would have been worse if I had to do it on my back. The cost of the Laso water pump, Motorad thermostat, gaskets, and 2 gals of coolant was $300. Oh, the plastic impeller on the old water pump looked perfect and the bearings sounded fine.

.

Link to post
Share on other sites
The cost of the Laso water pump, Motorad thermostat, gaskets, and 2 gals of coolant was $300.

That's just about the same money I paid for all OEM Porsche parts from Sunset. Pump was $209. Gasket is $6. Thermostat was $30ish and the coolant was about $24 gallon.

Edited by White987S
Link to post
Share on other sites

Water pump usually goes from 50k miles to 70k miles, crawl up underneath and look for weeps and see if you can feel any slop in the pulley. If you have stock exhaust its usually not too bad to replace. The water pump is easy to find, if you dont already know, if you're looking at the back of the car its on the driver side, on the bottom, at the rear of the motor, its the lowest, farthest left, pulley.

Theres some pretty good DIY's on the web. Order the part from Suncoast, they're the cheapest by far, and while you're at, if it hasn't been done before, might as well change out the serp. Belt too.

The water pump itself is nothing more than a small aluminum cover with a pulley on one side, and a plastic impeller on the other, i bet its no more than 4 or 5 inches thick. The problem is the engine cradle is so close to the back of the motor that there isnt enough room to pull the WP out and then drop it down. I have a full AWE exhaust, and if it wasn't for that, I could of probably had it out and reinstalled in an hour or two. But with the AWE, the whole exhaust system had to be removed so that the bracket would move enough out of the way to get the pump out. I was so frustrated as I was only lacking about 32nds of an inch to get the pump out with the exhaust still installed. Murphy's Law...

But its not a hard job, just takes some time and small carny hands, haha.

Link to post
Share on other sites

Mine started acting up at around 75K.

I replaced it with a NAPA water pump that was not suggested. I have 86K now and the pump is hanging in there.

Someone on some forum said they took it out through the top. Wrong. Don't try it. Waste of time.

You have to remove a couple hoses underneath and drop it down.

For a first timer... it is not easy. One 15mm bolt (I think it is 15 mm, maybe smaller) is hard to get to and if you use a torque wrench, which I used, it gets tough.

The OEM gasket is not just for the pump alone. Don't get frustrated. Just put the new gasket over the razor thin

original gasket and all will be well.

Don't forget to use the proper coolant and your coolant light will come on for a while until you burp out all the air and keep adding coolant. Good Luck.

Link to post
Share on other sites

Mine failed at 103k miles, awkward to do but not that bad if you've got axle stands and a desent high lift jack, bleeding can be an issue, I vented mine from the top of the radiators in the end. Wear gloves also OAT stings like hell if you get it on you!

Link to post
Share on other sites

Oh yeah, on top of the coolant fill cap is a weird little black mechanism with a metal spring/clip...thats a vent, just pull up on it and flip it so that it stands up and then drive around a bit with it like that, that will help vent away the air bubbles as they work loose.

Link to post
Share on other sites
  • 4 years later...

Replaced my second WP not too long ago.  All OEM parts.  They have fairly poor service life.  (106,000 miles at the time).  Did the job myself but had considerable help from Rennlist member who had done it a bunch.  I took off my left header to make access to the thermostat easier (which I also replaced).  Parts all from the Porsche dealership in Portland.  I also used a special vacuum system to help purge the air from what is a fairly convoluted system.

 

Dan

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.