Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

CDR-23 Blink power light, like loose connection


Recommended Posts

Hi, does anybody have any idea why the power light on my CDR-23 would be blinking as if it has a loose connection?? I've had the head unit out and checked all the external connections, they are all fine. Also i've had the front face off, and the circuit board looks ok. If you clout the underside of the unit it flickers.....????

Am I right in thinking it should be on all the time, even when the radio is turned off?

Any ideas???

IMG_3632_zps41c18568.jpg

Link to comment
Share on other sites

Tonight I striped the whole unit down and cannot find anything that looks wrong. Whatever it is it's not just one LED as i'd thought as there are three around the button that all act the same. Also it's not effected by movement or bumps (as i'd initially thought). No amount of bumping, wiggling connectors or pressing connections has any effect on the blinking.

Do any electronics folk have any idea what could be causing this??? If it is something giving up the ghost, then I wish it would hurry up as i'd be happier with the lights not working at all rather than this. As at night its very annoying in the corner of your eye.

Link to comment
Share on other sites

Thanks but going by the type of fault, I doubt its a re-coding issue. It flickers and fades in and out. There is nothing regular to it.

I'll get a local automotive electrician to have a look and see what he thinks. Getting Becker to even check it is going to cost hundreds, which is far more than i'm willing to pay, when the unit works perfectly in every other respect.

One thing, should the CDR23 have GAL? It does not show in my settings.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.