Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)
cburke996

Loose front end / steering feel

Recommended Posts

I've had an issue with my '01 TT for a little while now. The front end occationally feels loose and vague in regards to steering feel. The weird part is, it isn't always consistent. It usually takes some rough/uneven pavement at highway speeds (55-65+?) and all of a sudden steering feedback sort of gets more numb, and I can move the steering wheel back and fourth with somewhat of a lag in response. Another symptom that is probably related, is the steering wheel tends to have vibrations in it more than normal. I don't feel the vibration driving around normal roads, only highway speed.

In an effort to fix the issue, I've done the following (from oldest to most recent):

1. Rennline drop links were installed, this was not trying to fix the problem but worth noting.

2. I had new tie rod ends (inner and outter) installed by my shop, along with a full alignment to factory turbo specs. Had new rear tires put on (fronts are still healthy) and all wheels balanced. Once I got the car back, the problem still persisted.

3. Next step, I ordered new front control and track arms, OEM 996TT parts from Pelican. I installed them myself this past weekend, also put new front swaybar bushings in. Torqued everything to spec, except the ball joint and the chassis mount on the control arm. Couldnt get a socket on them, so I made them nice and tight with wrenches. Note: I tightened the control arm chassis mount with the car on the ground, so the bushing isn't stressed when it is sitting static.

This is where I am at now. The problem still persists, and I am getting pretty aggrivated by it. Now I'm asking the communitiy what my next step should be.

What I am thinking it *might* be:-steering linkage-rack mounting points-internal to the rack (Hope not! $$)-subframe mouonts/bushings-Front diff mount?-Strut mount (although it doesn't clunk or make typical bad strut mount noises)

Any input or thoughts? I don't want to just keep throwing money at it, and I am competant enough to do a lot myself. That said, I am not opposed to bringing the car back in. The hard part with that is, Sometimes the car feels OK (esp around town) so my shop might not see what I am talking about. But it is once you hit the bumps at highway speed that the problem surfaces. Then even on smooth pavement, it is like something gets upset and the car still feels bad for a while.

Thanks for taking the time reading my long post, I truly appreciate it.

Connor

Edited by cburke996

Share this post


Link to post
Share on other sites

What size wheels? Stock or larger?

Vibration could be wheels and or tires, out of balance, broken inner steel belt, not N rated tires.

Suspension stuff is always hard to diagnose.

If you're running 19" wheels, that's the culprit.

Share this post


Link to post
Share on other sites

Hi. I was just wondering if you had any luck correcting your front end problem? I have an '01 Turbo with the same issue.

Share this post


Link to post
Share on other sites

The car was not designed around 19" wheels. Just because they fit and lots of 996 guys use them doesn't mean they work better. I tried using them once long ago against better advice, but the side effects were adverse at the limit and when I switched back to 18"s all those issues went away. Running 19" wheels on a car that was not designed around them changes the suspension geometry enough to not function properly. There are other reasons too. Car was designed for specific overall diameter and with the AWD system a specific ratio of diameter front to back. No matter what tire you fit on a 19" wheel you'll never match the OEM diameters. Plus generally when you increase wheel diameter you have to increase tire size, sidewall gets shorter, wheel weight goes up, tire weight goes up, wheel flex goes up, weight distribution of the rotating mass gets farther from center. So... Puts more stress on the steering, which changes the steering feel. Wider front tires, even by a small margin, doesn't allow the weight to transfer enough to the tire on the outside as the inside tire now has more grip too. Wider tires work well but only on a car with the suspension geometry that is set up for it. Shorter sidewall now means less tire flex which means the suspension needs to compensate or you risk loosing contact and possibly bending a wheel. Its just not a simple swap. Porsche had to make lots of suspension changes to the 997 to get 19" Wheels to work correctly.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Pkcayenne
      Hi all I’ve been fighting with the cayenne again 
      let’s me put the key in and turn it then I get steering fault as attached any ideas of a way around this or a reset thanks car won’t start 
       
       

    • By 318touring
      X-posting from other forums as this seems to be a rare issue? 
       
      Car is 2010, C2, PDK
       
      Has anyone had this issue? 
       
      I have read a post or two where people were just leaving things be. 
       
      Would appreciate getting any feedback on what could be the cause. I have checked the power steering fluid, and it was full. 
       
      The video is of the rack itself. 
       
       
       
      Thanks!
    • By Pkcayenne
      Hi cayenne 04 CTT weirdness the below list of functions was intermittent now nothing works 
       
      buttons on steering wheel 
      tiptromic button on steering wheel 
      wipers
      cruise control 
      pin out adjustment 
       
      all functionality on the steering wheel except it steers perfectly all fuses are good errors as attached any ideas was intermittent

    • By nwGTS
      I am wiring indicators, horn and brights (for flash) to an OMP steering wheel hub with buttons to my 2012 997.2 GTS.  I need the wire diagram of the indicators and brights on the steering column so I know which wires to tap (horn is done already).
       
      Does anyone have this diagram or know where I can find it?
       
       
      Edit: Looks like i need the wire diagram for these two specific parts,1 and 3 in the embedded image.  3 is the switch would probably be the one I want.  1 is the control unit and would be helpful to have but redundant if I have 3 and I probably need 3 anyway in order to test any wiring done on 1.

    • By 2lflat4
      The vehicle is a 2005 997 Carrera 3.6. I cannot find the part #'s for the 3 power steering pump mounting bolts. They are exposed after removing the power steering pump pulley. In the attached picture you will see 3 holes in an upside down U shape behind the triangular pulley mount. I tried my local dealer without any luck.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.