Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)
xlr8n911

Intermittent "whooping" noise when engaging the clutch on C2

Recommended Posts

Hi everyone, my 99 C2 runs strong except for a couple of concerns. First, I have a cold start chain clatter that I will address with new tensioners (eventually). Since I have owned the car however, I have an intermittent "whooping" sound when I engage the clutch. It seems to happen more if the car is rather warm. The clutch does not seem to slip and like I said, the car runs strong. I am thinking that it is a sound related to the release bearing and nothing to get too screwed up about. Any thoughts from the community?

Edited by xlr8n911

Share this post


Link to post
Share on other sites
    You can remove these ads by becoming a Contributing Member.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Mike Blaszczak
      Hi!
      I have a 1999 C4 coupe with a manual transmission. Earlier in the spring, I had the transmission repaired -- 2nd gear replaced and the pinion bearing replaced, too.
      Since then, I installed a short-shift kit myself.
      Today, I noticed that the back-up lights aren't illuminating. All the gears engage fine, including reverse, so I don't think there's an adjustment problem. I don't know if the lights were working or not before my short-shift installation.
      What are the likely causes for the lights not working? Switch wasn't reconnected after tranny work, or the switch is bad, I guess. But could my short-shift installation be causing the problem?
      Thanks!
       
    • By Amber Wells
      I have a 97 tiptronic non turbo boxster. I blew my front seal so I need to rebuild my tranny. I just need to know what the parts numbers are for the bushing and seal.... I cant seem to find em and want to make sure I order the right parts.
       
      I heard you can actually order a larger bearing and seal and then machine out the tranny where it goes into and in turn avoid this sort of issue for much longer.. if that helps identify what im needing here im sorry im sort of lacking in the lingo im still learning and will update with a better description once i can go over it again with the boyfriend.
    • By SPIRO
      Hi everyone.  My 2006 Boxster S suddenly started making a squealing noise.  Noise goes away at higher RPM, only to come back at lower RPM and at idle. Not related to gear or clutching at all. Noise seems loudest at the rear of the car; I can hardly hear it inside with the windows closed.  Is this a serpentine belt issue? Or the bearing of some engine accessory? I have 50,000 miles, and have already changed the serpentine belt once, around 4-5 years ago,  just due to age of the car. I have not yet had the time to open up the engine compartment to look further. If it's a belt, then I would expect more noise from inside the cabin, would I not?  I have attached a recording indicating the squeal going away when I rev the engine.
      Recording 26.wav
    • By Jimbowne
      Hello all,
       
      I've got a 2008 997 C4 w/ 56k miles on it. It was cold this morning (30 degrees F) and I noticed clutch slip for the first time since I bought the car in higher gears under full throttle. The clutch pedal feels very mushy and lost alot of its spring on the return. I stopped by my local shop and he confirmed its the clutch.
       
      The car is my daily driver but I do autocross about once a month and intend to track in the future. I told myself I'd get the light weight flywheel when its time to replace the clutch, and so it seems that time has come. I'm not adverse to the extra noise of the LWFW, but I've heard that you shouldn't do this mod on a C4. I see sharkwerks has a C4 project car with the LWFW so I assume it worked out, but who knows.
       
      Aside from the flywheel obviously I need a clutch. I've been looking at the Sachs stage 2.5 performance clutch kit, and it seems like a good option. I've also heard that the BBI clutch slave cylinder is an upgrade that would be helpful for clutch performance and feel.
       
      Questions:
      -Anyone have any experience with a LWFW on a C4?
      -Anyone have any experience with the Sach's stage 2.5 kit on a C4?
      -Any other clutch kit recommendations?
      -Anyone have any experience with replacing the clutch slave cylinder?
       
      Note: I'm going to get my IMS bearing inspected but if its not leaking I think I'm going to pass, seeing how I have 56k miles on it with no issues. Perhaps its past the infant mortality stage?
       
      Thanks,
       
      Jim
    • By David MB
      Help - i have a 2003 Boxter tiptronic s - in great shape other than a shrill loud noise like a Kazoo that only happens above 78mph - it sounds as iff coming from around the mirror area of the windscreen but then occasional sounds like its coming from the speaker area passenger side - that being said could be sound transference. Read a number of blogs about badly fitting windscreen so put tape over top rubber seal and body but still there - - as a say like a kazoo at 78mph with hard or soft top - absolutely driving me mad - any help gratefully received.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.