Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)
  • ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By Garra671
      Recently I had been noticing issues with my cooling system the coolant temp guage would go past the 0 on 180 and I wouldn’t hear fans or anything. (Already tested fans and resistors and relays).   The temperature Will continue to creep up if I sit still, with no signs of fans, AC OFF.

      I replaced the coolant temp sensor. Problem fixed!! Then same issue again it seems after a week of driving.  

      Now i currently have ordered another temp sensor just Incase I maybe did something to cause the other new one too fail, I’ll be changing it again today.

      However I was doing the climate control hack to check my actual temperatures today while doing a short troubleshooting drive. And I noticed my oil temperature said 0, which is physically impossible 🙄


      Is it possible the oil temp guage is throwing off the coolant sensor?    Is it even possible for the oil temp sensor too go bad but not the oil level sensor? (They are a 2 in 1 sensor)   

      THANK YOU IN ADVANCE
    • By Bardia Manafi
      Hi all, just purchased a 1961 notchback 1600s, I have never drove a Porsche until the day I purchased this car, got the bug now and i love Porsches more than ever now, the car is in very good shape, but i want to change all the fluids, grease all the parts, and do all the maintenance there is, the oil was so dark when I checked the level and it was all the way to max line of the stick, i would appreciate if you guys can tell me where to buy all the maintenance parts, and where can I buy the shop manual, and what are the things I should do, there is a small leak on the floor from engine very small, but a palm size of oil from transmission on the ground,  thanks guys cheers😁

    • By salamander
      I have a 2007 C2S manual with about 132K on the odometer.  A low oil pressure light has started to show up at idle after the car is warmed up.  It seems as if the light is gradually coming on more frequently.  The pressure gage on the dash reads around 0.5 bar when the light comes on.  When the car is cold the starting pressure is around five bar and is about 3 bar at 3000rpm.  As it warms up the pressure drops to about 2 bar at 3000rpm.  I always run 0-40W Mobil 1 and change the oil every 5K miles.  With the engine off and turning the key one click the pressure gage rises to about 0.1-0.2 bar.
       
      Can anyone help me diagnose this issue?  Would be a sensor or something mechanical?
       
       
    • By andrewjt19
      Hello everyone,
                Does anyone have or know where I may have the bolt torque specs for a 2008 Cayenne Turbo? I need pretty much the specifications for all the bolts and nuts that would be included in a block replacement. I'm getting the back rebuilt by 928 Motorsports and reinstalling with an experienced friend. However, it's nearly impossible to find the specs for these motors. Additionally, if there's a place where I could find a complete 957 workshop manual, could someone please advise? Thank you.
    • By andrewjt19
      Just wanted to say thanks to the community helped answer some questions about the scoring on my 2008 CTT 957. My next question is, does anyone know where I may purchase a complete engine seals and gasket kit for a 2008 Cayenne Turbo? Or if these are unavailable as a whole unit, had anyone rebuilt their engine from the cylinder scoring or something similar and have a parts list of required seals and gaskets which need changed? Additionally, are there any other suggestions on parts that I should change some I'll have the motor apart? Anything would help at this point. Thanks
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.