Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Recommended Posts

Spent the afternoon under the front N/S corner of the 04 Cayenne Turbo, looking to replace the seals on the boost hoses and dump valve.

When unclipping the bottom turbo hose from the intercooler, I was stunned to find at least 1/4 litre of oil pour out of the hose onto the floor.

In all my years, I've never taken a hose off a turbo and seen that much oil.

Has anyone else on here taken the hose off the bottom of the intercooler on the N/S (Drivers side US & Europe, Passenger side UK) and experenced it full of oil? I'm worried about the state of the oil seals on the N/S turbo. Is this a feature of the Cayenne's turbo design??

I replaced all of the seals on the hoses at the O/S earlier in the year, and the bottom hose was dry. This N/S hose is shaped differently, but should it collect 1/4 litre of oil like this?

Thanks

Chris

Share this post


Link to post
Share on other sites

Normal to see a cupful of oil collect in that pipe.

My service advisor says it is due to the breather circuit of the engine etc.

I get both left and right pipes drained every year at the annual service and oil is always evident in the left hand pipe, very little if any in the right.

Nothing to worry about turbo seal wise, as long as oil isn't evident in your exhaust tailpipe.

Edited by bigbuzuki
  • Upvote 1

Share this post


Link to post
Share on other sites

Cheers bigbuzuki,

Yes, after speaking to my OPC today, I've been advised that the breather valve (pictured) is a common problem, gets dirty, sticks open and can cause this. £78 from the dealer, so I'll change it out and see how it goes

breathervalve_zpsded05019.jpg[/url]

Share this post


Link to post
Share on other sites

The breather can cause that but Porsche also say's to drain & clean the lower intercooler hoses at the major service intervals, 20K.

  • Upvote 1

Share this post


Link to post
Share on other sites

There's a TSB in here about replacing the pipe and henn coupling. And when doing so, everyone gets a dump of oil. "By design" apparently.

But... installing a catchcan is next for me.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By salamander
      I have a 2007 C2S manual with about 132K on the odometer.  A low oil pressure light has started to show up at idle after the car is warmed up.  It seems as if the light is gradually coming on more frequently.  The pressure gage on the dash reads around 0.5 bar when the light comes on.  When the car is cold the starting pressure is around five bar and is about 3 bar at 3000rpm.  As it warms up the pressure drops to about 2 bar at 3000rpm.  I always run 0-40W Mobil 1 and change the oil every 5K miles.  With the engine off and turning the key one click the pressure gage rises to about 0.1-0.2 bar.
       
      Can anyone help me diagnose this issue?  Would be a sensor or something mechanical?
       
       
    • By andrewjt19
      Hello everyone,
                Does anyone have or know where I may have the bolt torque specs for a 2008 Cayenne Turbo? I need pretty much the specifications for all the bolts and nuts that would be included in a block replacement. I'm getting the back rebuilt by 928 Motorsports and reinstalling with an experienced friend. However, it's nearly impossible to find the specs for these motors. Additionally, if there's a place where I could find a complete 957 workshop manual, could someone please advise? Thank you.
    • By andrewjt19
      Just wanted to say thanks to the community helped answer some questions about the scoring on my 2008 CTT 957. My next question is, does anyone know where I may purchase a complete engine seals and gasket kit for a 2008 Cayenne Turbo? Or if these are unavailable as a whole unit, had anyone rebuilt their engine from the cylinder scoring or something similar and have a parts list of required seals and gaskets which need changed? Additionally, are there any other suggestions on parts that I should change some I'll have the motor apart? Anything would help at this point. Thanks
    • By OscarAH1W
      Transitioning from previous thread to new one--  Replaced the water pump and performed the 60,000 mile service in my 04 Turbo Cab.  Car runs great except now I am getting overboost to 1.0-1.3 bar.  I don't hold it there to be sure.  That said, I realize it is likely a vacuum issue but the only lines I touched during the repair are the one from the Y-Pipe to the switch and the one from the switch to the plastic line that goes to the driver side of the engine.  Flashlight and inspection mirror show the 3rd line on the underside of the switch to be connected.  Any thoughts on where else to look?
       
      Thanks
       
      Owen
    • By 9552T500
      Hi - on my 06 CTTS, over the last few months I noticed  occasionally awful smell inside the cabin while driving. My research so far indicates that it is emitted from vents when AC system is on. Believe it smells like sth. burned, and is not present when I switch AC system completely off. Did anybody experience this before on a 955 Cayenne, Turbo or Turbo S ? Thanks in advance. 
      PS.: side note. It may be coincidence or completely unrelated, but as far as electrical problems I am noticing for about comparable amount of time that the  horn is dead (silence when pressing the steering wheel center...). 
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.