Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)
Sign in to follow this  
PKN

Replacing O ring in turbo to pressure hose (drivers side)

Recommended Posts

...This should be easier than it looks. I have removed the pressure hose from the turbo (cylinders 5-8) and noticed that the aluminum casting between the pressure hose and the turbo has some play so while I was doing the job I thought I would replace the rubber O ring at this joint.

Unfortunately, the casting has a short rubber hose attached going to what looks like a vacuum control pod and there is not enough movement in the hose to pull off the casting to get to the rubber O ring. I loosened the clamp at the vacuum switch but the hose but it wont pull off and I don't want to break the plastic fitting. Is the only answer to cut the hose and then replace it?

All advice gratefully received

Steve

Share this post


Link to post
Share on other sites
    You can remove these ads by becoming a Contributing Member.

If you search in Rennlist.com. " DIY 05 CTT Pressure-Pipe O-ring removal" here you will find the info. Sorry couldn't figure out the link.

Share this post


Link to post
Share on other sites

Many thanks - I found it. The rubber hose is still not prepared to budge so I will cut it off and replace it as the easy solution. Parts arrive tomorrow and hopefully I will be driving her again this weekend

Steve

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.