Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

997 Turbo oil smoke on start up-advice please


Go to solution Solved by Ziff,

Recommended Posts

Hi there,

My 2008 turbo is suffering from producing a smoke screen on cold start, and occasionally on a warm start up. Having had quite a few flat sixes over the years I know some say that white smoke on startup is normal, but this smoke I think is more oil burn off smelling and is thick and embarrassing. I spoke to the dealer I originally got the car from and their view is "they all do that from time to time" but my previous 997 turbo never did.

There doesn't seem to be any other smoke after the first few seconds after start up whatever driving conditions are after that. Also it seems to be the left hand pipe that smokes more than the left.

The car drives perfectly otherwise and I have always used mobil1 oil.

Any ideas on the fix as I don't think I want to just live with it on a car of this value

Link to post
Share on other sites
    You can remove these ads by becoming a Contributing Member.

  • Moderators

No they're not, but such problems can have various causes. You could see whether any of the turbo's is leaking oil, check the charge coolers for oil residus and at the same time the oil return pipe for cloging. There may with the engine itself, cylinders/piston rings for example, also be something wrong.

Link to post
Share on other sites

Hi there,

My 2008 turbo is suffering from producing a smoke screen on cold start, and occasionally on a warm start up. Having had quite a few flat sixes over the years I know some say that white smoke on startup is normal, but this smoke I think is more oil burn off smelling and is thick and embarrassing. I spoke to the dealer I originally got the car from and their view is "they all do that from time to time" but my previous 997 turbo never did.

There doesn't seem to be any other smoke after the first few seconds after start up whatever driving conditions are after that. Also it seems to be the left hand pipe that smokes more than the left.

The car drives perfectly otherwise and I have always used mobil1 oil.

Any ideas on the fix as I don't think I want to just live with it on a car of this value

100% normal. Very sporadic, but normal. When you end your drive, you can let the car idle for a minute or so, then likely won't have smoke the next start.

DC

Edited by therock88
Link to post
Share on other sites

Thanks for the feedback both. I will try longer idling time and see if that helps. Generally I always drive gently for the last few miles of a drive to let everything cool down before turning off but will haven't then let it idle in addition.

Thanks guys

Link to post
Share on other sites
  • Solution

My 2007 did that too, but as mentioned, it was aporadic and when i had it serviced, I asked and was told there was nothing wrong. Keep in mind that there are oil seals that seprate the two side of the turbos that may drip a little oil until heated up. If the smoke screen was constant and lasting more than a couple seconds and if it were happening under load or boost, then I would be concerned.

Walt

Link to post
Share on other sites

Thanks Walt

Thee is never a problem under boost or load so suspect it is not a big issue, but I've decided to get it checked by a specialist next month. If I don't get a big bill I might invest in an ECU remap to celebrate, man maths at its best!

Link to post
Share on other sites
  • 2 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.