Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)
Sign in to follow this  
dpullan

Michelin Pilot Super Sport Tire Choices

Recommended Posts

I have a 2003 911 cabrio (no PSM) with the Carrera 18" wheels and need a new set of tires. I have decided on the Michelin Pilot Super Sports based on reviews and price. Unfortunately, they do not make stock sized rear tires (285/30 ZR18).

My choices for rear tires are:

285/35-18 - (taller) or

265/35-18 - (narrower)

My choices for front tires are:

225/40-18 - Original size

235/40-18 - Seen others recommend... not sure why

2 questions:

1) Which rear tire size would you recommend?

2) Why should I change the size of the front tires from the original size?

Thanks for you input.


Share this post


Link to post
Share on other sites

hey there. Tire choice is always a challenge somewhat. As I learned over the years from my own arrogance and stupidity , its really important to realize Porsche specifies components for a reason. This being said, your choices look correct for stock 18's.

What I discovered on my 2000 C2 RWD coupe was the total rolling circumference makes a difference on handling and comfort at speed. After playing around on a number of web based tire size calculators, I settled on 225 40 18 up front and 295 30 18 on rears because the difference on outside circumference was less than 1/16". I presume your rear rims are 11". but these would still fit on 10.5 rears.

The other aspect not mentioned is offsets. Again, I presume your rims are stock and ET's are 50 upfront and 65 at rear. 225's upfront give you 8 inches of rubber . For aggressive driving, they are more than enough to point the car in the right direction at normal street and highway speeds. 295's give you about 11.5-12 inches of rubber at rear. They look wide, are wide and act wide.

Not sure what environment you live in, but its worth looking at hardness too. Im here in Florida. Heat and rain are primary considerations. I like soft compound and am running Kumho SPT's all around. They're cheap, but well made. ( others may disagree ). The downside of any tire is wear. Im only getting about 9-10,000 miles on the rears, but I dont care. Id rather eat up tread then end up wrapped around a tree.

good luck. lets us know your decision. take some pics :-)

Share this post


Link to post
Share on other sites

I have an '01 996 Cab C2 and recently replaced my tires with the all new Michelin Pilot Sport AS 3(all season). I went with 225/40ZR18XL on the front and 265/35ZR18XL on the rear. I couldn't be more pleased with the choice. The grip is excellent and the price was right. I live in Michigan and planned on driving this winter on dry roads but we haven't seen the grass 12 weeks!

Share this post


Link to post
Share on other sites

I have a 2001 C4 and live in TX. I have PSM and made sure the dia. was as close as possible and a soft compound, sticky is better then slippery. So I chose Kumho SPT's 295/30ZR18 rears and 225/40ZR18 fronts.

Share this post


Link to post
Share on other sites

2003 C4$. Previous '79 911SC. I've used many tire brands over many years. I've always run sticky summer tires as I live in a rainy, wet winter climate with no snow. Always look for the AA traction rating for wet weather driving. By far the best tires I've ever used are the Michelin PS2's, Porsche rated N3. No, Michelin is not paying me for posting this note.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By stephen magee
      wires came out of my camshaft sensor and not sure what order they are
       
    • By Kevin Bryck
      Okay this is REALLY specific.
      The adjustable tension cable on the drivers side of my cabriolet disconnected at the top where it threads (8mm) into the top frame, not at the bottom where it snaps onto the ball.
      The is a larger diameter (10mm?) clean smooth painted hole where the cable needs to thread in, which leads to the presumption that there was a nut on the back side?
      Searched all over including removing driver's side rear 'door' panel and fishing around with a magnet but no loose nut found.
      Looks like getting to back side of this frame casting would entail a major disassembly of the cabriolet top frame?
       
      Also, what does this clip that goes over hydraulic cylinder do?
      Right side clips is in place about halfway down length of cylinder.
      Left side clip was down around the base of the shaft.
      Replacing it where there appears to be a shiny spot looks like it would interfere with the cabriolet top potentiometer arm.
      Right cable threaded into frame at top
      Right cable threaded into frame at top
      Missing cable location
      Smooth clean painted hole in top frame where 8mm cable end is supposed to thread in
      Left cable
      Left upper cable end with 8mm thread
      Clip question
    • By davemac
      Hi everyone,
       
      I've had a spoiler warning lamp on since I bought my 1998 996 convertible a few years ago.  As an electronics engineer, I decided I may be able to tackle this issue myself. Before starting, I have read numerous previous posts regarding this issue, and what the fixed-wing bypass harness (996 612 070 51) does.
       
      When the rear spoiler is elevated, I'm getting zero Ohms between the Grey/Brown (A2) wire and the Brown (A5) wire, as expected. This becomes open circuit when the lid is lowered. There is then zero Ohms between the Brown (A5) and the Green/Grey (A4) wires, again as expected! The switching of the brake lights works normally too, but still the warning light persists.
       
      I am wondering if there could be a corroded plug/socket further forward from the rear of the car because the one at the back is very clean and the microswitch states are normal in both positions. I'm not sure if this is a common fault, but I'm guessing it probably isn't as I can't find anything online. One thing I have noticed is that although the manual up/down wing rocker switch works, I have to keep is pressed down until the wing is down. When I try to elevate the wing manually, the switch triggers the latching function of the relays, but when the spoiler is fully up, I can still hear the motor continuing to turn and the gears slipping inside the rear mechanism. The gears will eventually strip and I'll end up with a bigger problem, so any thought on this nuance would be greatly appreciated.
       
      Many thanks,
      Dave

    • By henryhkl
      Hi all
       
      I have a low oil pressure problem on my 2003 996 C4S RHD / ROW, Tiptronic.  Owned since 2012, oil change at least annually first with Mobil 0W40, more recently Fuchs or Liqui Moly (green) 5W/40.  Looking for help from anyone who has seen something similar - I've looked at various threads on this topic but couldn't find the exact symptoms.  
       
      Last oil change was done in Sept 2018 with the Liqui Moly green.  About two months later, the "oil pressure too low" red light started to come on intermittently.  Either on start-up, or sometimes when slowing down or waiting at the lights.  It doesn't stay on forever, just flashes and goes.  Had the oil pressure sending unit replaced (its been faulty for a while and yes I know I should've replaced that way earlier.. now not sure if this has been masking the problem at hand)..  After replacing the unit, I assume the gauge is accurate and it shows:
       
      - On cold start-up: gauge stays at zero for first 5-7 sec.  The red low oil pressure light flashes on, then the needle moves up to 3 bar max
      - On warming up, the needle will drop and eventually settle on 0.8 bar (i.e. after 10 mins and water temp rises to normal operating temp)
      - Oil pressure does NOT rise on acceleration - i.e. when rev to 3-4K, the needle doesn't move at all.  It used to move with the revs
       
      I've also had the oil pressure relief spring / piston / gasket changed (and oil topped back up of course) with no difference.  I'm thinking of the following next steps (in order of complexity and $$):
       
      1. oil change / filter change, check filter for metal and ensure it isn't collapsed / crushed
      2. mechanical gauge to confirm that oil pressure is indeed low, and it isn't an electrical misreading
      3. inspect oil sump - check for blockages in the oil pickup tube
      4. drop engine - check oil pump for failure
      5. rebuild engine - have reached out to a few builders who have said it could be crankshaft bearings worn, engine no longer to hold pressure.  I guess this would be worst case.
       
      I hope it ain't 4 or 5, but something has worried me about this problem..  Why I say above this oil pressure problem might have been masked by the faulty sending unit?  My gauge used to rise to 1.5 bar even before the engine fired up but with ignition on.  My indy looked at that and laughed "how could there be oil pressure when the engine isn't on!"...  So when the engine did start the gauge showed 4.5 on cold start, and it would drop to about 2.x when at operating temp.  So..  if my sending unit was faulty and was adding an additional1.5 bar of pressure to the gauge..
       
      Anyone experience similar?  Thanks.
       
      Henry
       
       
       
       
    • By gary_cs
      The left door key switch on my 00’ 996 c4 will not lock or unlock. I took the handle and bracket out of the door frame. I was told what usually breaks is the cylinder but nothing appears to be broken. I don’t want to buy a new key so simply replacing the bracket isn’t an option. Is there a straight forward solution or do I need a specialist??
       
      Any my feedback would be much appreciated thanks!
       
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.