Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)
Sign in to follow this  
krftwrk

Volkswagen Antifreeze in a 2000 Boxster?

Recommended Posts

Are you flushing the system? Use 1/2 VW coolant and 1/2 distilled water. You need about 3 gallons each.

 

If you just need to top up the Boxster, just add distilled water. No need for coolant.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By Alan Huey
      I recently had to replace the water pump on my 2001 Boxster.  This all went fine, however, the red light to the right of the temperature gauge is blinking at 1 Hz.  I've read this indicates low coolant level.  I followed the factory procedure to bleed the system and it is filled to the max, but the light still blinks.  Also, the gauge is flatlined to the left.  I replaced the temperature sensor near the #4 cylinder head without improvement, and the wires "look" ok.  All the fuses are good.  Does anyone know the procedure to troubleshoot this wiring?  Or the pin and socket numbers for the wiring diagram?  The temperature gauge worked fine before the water pump blew up.  I did recover most of the impeller, but a few small pieces are in there.
    • By gowestwardho
      New to this Board and looking for some immediate guidance on a specific problem with my coolant reservoir (leak). If anyone can answer this, it would be greatly appreciated. I have an 2001 S with 65,000 miles. I noticed the aforementioned coolant leak. I've ordered the #01 new style cap (wish Porsche had bothered to tell me about that one!) and am waiting for it. in the meantime I am either trying to seal the leak with some plastic weld that another user had success with - OR - I will try and replace the tank itself if need be.
      HERE'S THE QUESTION THOUGH:
      In every posting I see it refers to just how difficult this DIY job is because "you have to remove the hoses from inside the engine compartment on the other side of the firewall", and "almost need drop the tranny to get to the c-clips".
      BUT MINE SURE DOESN'T LOOK LIKE THAT! (See attached photo) All I'm seeing are three rubber coolant hoses with c-clamps on both ends, and the oil fill tube, and the oil dipstick line. That's it! So I am left wondering if my build got a newer style coolant reservoir that is easier to remove - OR am I just that stupid and asking for big-trouble in trying to do this?
      Anyone know if I remove those three hoses can I A) either move the tank around enough to get to the underside and REALLY seal the leak? OR 2) remove the tank entirely and replace it myself?
      Oh, man thank you if you know the answer!

    • By Jactwist
      1999 Boxster S Tiptronic 57K miles.
      Spent good part of the afternoon trying to get to the bottom of coolant loss from the expansion tank. Wife went to use the car yesterday and the red light started flashing, checked the expansion tank - empty. Took about 3 litres to refill.
      Today I went through a 'bleed' procedure. Pulled up a spring loaded clip on top of tank, slowly filled tank, remove a fuse B1 to effect some sort of valve - apparently only needed for tiptronic system bleeds, run engine up to 90 - used cooking thermometer into expansion tank, reving engine every few minuets. There was a visible flow. The tank spilled over when it hit about 90(when the stat opened?) then settled down fine.This process took about 40mins.
      Reset spring clip, refitted fuse(which stopped the instruments working whilst removed), closed tank lid and took car for a spin.
      After about 6 miles steady driving pulled over and checked tank level - all good. Did another 6 miles with a blast up to about 6K revs in 3rd. Got back home and pulled over. all good. Ticked over for a few mins fine. Did one more lap of the block and pulled over; a large gush of water came out of the top of the tank -about 2.5Ltrs on to the road.
      Back to square one.
      Is there something I'm doing wrong?
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.