Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

New owner with a few issues! 1990 964 C4


Recommended Posts

Hello everyone, been snooping on here for a while now but I have recently sold my 1982 SC and treated myself to a 1990 964 C4 in guards red. 

 

Its just been fully resprayed so looks in fantastic condition! Just going to spend some money on new rear lights including the reflector and new front side reflectors just to get the exterior in tip top condition. 

 

Mechanically she is well. I need to fit a new fan belt tensioner and figure out why the washer bottle low level light is on. 

 

However my rear head scratching issues, the reason in which I'm here is the CCU unit isn't working as it should. If you put the fuse into no.1 in the fuse box underneath the bonnet the fan blowers will come on straight away regardless of whether its locked, unlocked, ignition on, engine running etc! It will run until the fuse blows after about a minute or so. Its an air con car but I can't say if that works or not. 

 

I've done a bit of investigation online but soon got bogged down in all this technical data etc - Where can I start first, check the fuses, relays etc?

 

Any help would be much appreciated.

 

Christian  

post-96746-0-33702300-1403779421_thumb.j

Link to post
Share on other sites
    You can remove these ads by becoming a Contributing Member.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.