Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Recommended Posts

Right then, the windowregulator of my 2004 CTT failed some time ago so I've ordered a new one on Ebay and replaced it.

When I did I made a smaal mistake whilst fitting and damaged the cable so it was a matter of time before it failed again...and recently it did.

So I ordered a new one and fitted it correctly this time.

All went well and it worked fine, however the window never really fully 'seated' at the top...there was always a very, very slight gap between the glass and the top of the frame...was there as well when it failed the first time.

Anyway, the regulator failed AGAIN...

So I'm wondering what could go wrong so quickly?? And doI align the glass properly as I can'tseem to get rid of the gap I've mentioned...

Any help greatly appreciated, this will be the third time I have to take the lot apart...getting rather annoyed with it....

Thanks!

Link to post
Share on other sites
    You can remove these ads by becoming a Contributing Member.

There's two white knobs or "bump stops" on the bottom of the regulator. Where it bolts to the bottom of the door towards the front of the vehicle.

Will the the door panel off, bring the window down and look for where it stops. Betcha it stops as it hits the 1st bump stop

Edited by AWDGuy
Link to post
Share on other sites

Sorry to be thick but: there's a bumpstop on the way DOWN you say...but my problem occurs when I wind the window UP...it looks as if the glass sits ever so slightly slanted sideways so it doesn't close properly on the RH-side of the door (when stood outside)...

And now-one as to why it keeps breaking regulators?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.