Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)
Saibot

strange issue with window switches (during regulator replacement) 996

Recommended Posts

hi all.

 

i'm a bit stuck. i just replaced my window regulator and was in the process of adjusting it so that it closes properly when suddenly, my switches stopped working.

 

It's strange because both my passenger side and driver side window switches dont work (i was only working on the driver side regulator), but both windows go up and go down when I open / close the doors. I whipped out my multimeter as well to test the switches to make sure they're getting juice and im seeing 1.57v from one contact to ground (is this normal?).

 

Anyone have experience in this issue? I checked the fuses as well, everything seems in order. I just need to be able to lower my window so i can loosen the bolts and adjust.

 

Thanks in advance

 

 

Share this post


Link to post
Share on other sites
    You can remove these ads by becoming a Contributing Member.

Did you do the re-teaching process on the windows to "teach" them their limits again?

No, was still aligning the window to fit horizontally since there was massive gap between rear quarter window and main drivers window. Re-teaching was next on my to do list when the switches stopped functioning all together.

Now that I think of it, both window switches stopped working right after I raised the window to the highest position and closed the door to check alignment (i can confirm microswitches and regulator work as window goes up when door is closed and down when door is open).

Battery is fine. I started the car and let it run for 15 min to ensure battery was charged. I'm leaving battery disconnected for a few hrs to see if it might reset some setting in the ecu.

Share this post


Link to post
Share on other sites

Thought I'd post an update for anyone else that goes through this situation in the future: it was a fuse. I believe C3

Share this post


Link to post
Share on other sites

Lilkely:  C3: 15 Amp: CU CLS ALARM, Power Window, Sun roof, CU Power Top, Inside light

Share this post


Link to post
Share on other sites

Ok, here's a strange Saturday. Last weekend I replaced the driver's side window regulator with a new genuine Porsche part. My ride is a 2003 c2 cabriolet by the way. I had removed the old regulator which was trashed before opening the new one. Turned out the new regulator had a crack in one of the green plastic ferrules. Having no other option, I installed it anyway. Worked perfectly. I was concerned about the crack though, and contacted the seller. They sent me a new replacement. I installed the new genuine Porsche regulator today. Then the window would only raise about halfway. I tried everything I could find but to no avail. I therefore took out the uncracked regulator and reinstalled the cracked one. Now the window once again works perfectly. Any ideas on what the heck is going on? Any thoughts on this greatly appreciated.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.