Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Recommended Posts

Hello,

 

I would appreciate some input on the following issue as I understand it is common with the 993 series:

 

The engine light is on; the dealer diagnosed the problem, and find out CO build up: "Problem is in air flow to air injection ports in exhaust ports. Suggest to treat passages chemically in attempt to clear airflow. If not possible, cylinder heads will have to be removed and sent to a machine shop to clear. At this point, it is recommended that the valve guides be replaced and valves checked."  Also, I was told this issue will happen again after about 20K miles or so...

 

Well, this is about a $1,800 fix option that may work as per the dealer...The car will not pass smog at this point.

Anyone experienced this issue with their Porsches? Any recommended solution?

 

Thanks,

Share this post


Link to post
Share on other sites
    You can remove these ads by becoming a Contributing Member.

This is common on the n/a 993. Not as common for the 993 Turbo, but it does happen. You should post this same question over on Rennlist. Many experienced owners over there.

 

Side note, a great oil for your car is Mobil V-Twin 20W50.

Share this post


Link to post
Share on other sites

Btw, thank you White987S for the Rennlist posting suggestion; lots of help regarding my problem from that Forum too! :thumbup:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.