Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)
j_beede

74mm, 74.4mm, 76mm, 14 flats, 15 flats... (rant warning)

Recommended Posts

As the owner of a MY05 997 C2 I am already dealing with the IMSB "mystery" until the clutch gets done. Too bad since J. Raby recently mentioned the "magic wand" which should have been part of my PPI. Apparently this is a gadget that can identify which IMSB is installed in M96/M97 without dropping the transmission. Now they tell me.

 

I had intended to change my oil filter yesterday... no luck as I spent my garage time looking for an oil filter wrench for my stock plastic canister. It seems that either people are using the wrong wrench (with mixed results) or P has done it again by using a variety of canisters on 997.1. Hence the title to this topic. I thought paying $36(!) for the cartridge at the P dealer was bad enough without paying $$$ for the billet unobtanium filter wrench that they offered--especially since many 997 owners claim to be using wrenches that they paid $3-5 for at Pep Boys or Kragen or WalMart. 

 

I am not near to any of those outlets so would like to order from Amazon. If only I knew to order 74mm, 74.4mm, 76mm, 14 flats, or 15 flats... I suppose I could buy all six combinations and hope that one fits. That would cost less than half the cost of the 996.xxx.yyy.xxx wrench plus round trip to the dealer.

 

I know about the LN spin-on adapter and will do that at the next oil service.

Share this post


Link to post
Share on other sites
    You can remove these ads by becoming a Contributing Member.

I have the official Porsche filter wrench purchased 25 years ago for use on a 944. Also fits 997.1. It 's a Mann LS 7 with 14 flutes but the exact diameter is difficult to measure since the flutes are recessed in the cylinder. These wrenches are available on the web for much less if you shop around. Interesting about the "magic wand." Could you please provide more info on jake Raby's "magic wand" for determinining the size/type of IMSB or provide a reference. Thanks.

Share this post


Link to post
Share on other sites

76/14 is the one that you will need.

Share this post


Link to post
Share on other sites

75mm 14 flats (Pennzoil brand) worked okay. It is probably a bit too big as it sticks on the canister after applying torque. For $6 I have no complaints. 

Edited by j_beede

Share this post


Link to post
Share on other sites

MY05 C2 6-speed.

 

The 75mm, 14 flat filter wrench from O'Reilly (Pennzoil brand) worked but is really a bit too large. The wrench "stuck" on the canister after torquing and had to be coaxed off. No harm done.

 

You would expect an oil and filter change to be fairly uneventful. I had a couple issues come up:

 

1) Large aluminum drain plug and aluminum oil pan may not be the ideal combination. The drain plug broke free and spun out--finger tight--until about halfway out. Then it got snug again. A bad thread or two in oil pan. The new replacement drain plug threaded in by hand about halfway, then got snug, then spun in nicely for the last 2-3 turns. I was temped to chase the oil pan threads with a tap or steel bolt but left it "as is" for now as it torqued securely. Chasing the threads will surely leave tiny flecks of aluminum in the pan. Dropping the pan just to chase the threads seems like overkill as the bottom of my pan and garage floor are clean, dry, and oil free. I suspect the tiny bright specs in the filter were from the poor fitment of the drain plug. 

 

2) I started the oil refill with 7 quarts. The dash gauge reported low level--flashing low. Good. Added 1/2 quart and see one bar on the gauge. I slowly added oil until the gauge was at the upper arrow. Good. Took a drive to warm the engine and parked it. This morning with a cold engine I am above the upper arrow, all segments lit. 

Share this post


Link to post
Share on other sites

Welcome to the world of rubbish oil level measuring! Try not to get paranoid over it, trust me it is easy to do! I fill to one segment below full when cold, then when hot it reads full. Works for me, other may disagree. Remember it only reads the last couple of litres anyway, 400 cc's per division if I recall and at 410cc's it will illuminate the next segment so make your own mind up.

Share this post


Link to post
Share on other sites

jl-c,

That might have worked based on what I observed. I suppose I will be pulling the filter canister off to drain off about 550cc. Once I am calibrated I will know what to do next time.Using your method have you seen the level drop back down to one bar below the upper arrow when cold? 

...j

Share this post


Link to post
Share on other sites

This morning the level was right at the upper arrow, cold engine. Good.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.