Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)
Sign in to follow this  
myturbo

Problems with cab top

Recommended Posts

Here is one that seems to have everyone stumped, and I was hoping that someone has a place for me to start looking, because I'm out of ideas.

 

I bought my 2004 cab and it must have been altered for the roof actuation.  It was one-touch up and down, and I didn't need to be stopped.  Very weird thing happened several months ago and I've been looking for a solution and I am stuck.  The roof now only works when the car is in motion.  That's right, only in motion.  If I stop the car, the roof stops it's transition.  First thing I did was to go online to see what aftermarket things are available.  I found two.  One piggy-backs in line with a connector at the control unit behind the rear passenger seat, and the other piggy-backs in line into the immobilizer below the seat.  Neither of those are on my car.  Earlier I thought it might be the syncing of the two flap motors, because at that time I didn't realize I could get it up or down with the car in motion.  When my Porsche shop went to sync the motors, the guy told me he got a weird fault.  With the car turned off, he was getting an error that the car was moving at 13mph.  He reset it and we tried the top standing still and the top cycled several times.  When I drove it home, the next day it would not transit again until in motion.Is there anything else in the DME, immobilizer or top controller that can cause this problem?  What other mods are out there?  The top controller seems to be an original Porsche part (see pic)

 

I'm willing to take it into Porsche and ask them to get it back to original condition, but I don't want them doing a swap-till-you-drop approach, which would kill me in cost.  I'd like to have a bit more targetted approach.  Anything else I can try?

post-96986-0-91205200-1442330110_thumb.j

Share this post


Link to post
Share on other sites
    You can remove these ads by becoming a Contributing Member.

You can check to see if it has SmarTop or a similar device attached at the main connector.

If, then just disconnect it and plug the main cable back in.

 

post-1-0-49265800-1442334702.png

 

Share this post


Link to post
Share on other sites

By "main connector" do you mean at the top controller behind the rear seat?  if so, which of the three connectors should it be in?.  It is not in the most outboard one, where all the Smarttop modules I saw on line were connected.

Edited by derohanes

Share this post


Link to post
Share on other sites

From the rear of the car SmarTop is in the bottom left connector.

 

If not SmartTop then it is either something else, or faulty control unit, or a DIY mod of unknown origin. 

Share this post


Link to post
Share on other sites

By "main connector" do you mean at the top controller behind the rear seat?  if so, which of the three connectors should it be in?.  It is not in the most outboard one, where all the Smarttop modules I saw on line were connected.

Check under the driver seat. My remote top module plugs into the main connector there.

Share this post


Link to post
Share on other sites

Thanks guys, but it's not in the left-most position of the controller behind the seat, and as I mentioned it is not on the immobilizer under the seat either.  I'm completely baffled.  I don't think that it is a bad Porsche module.  If a module went bad, it must be an aftermarket one, which what I'm trying to locate.  At one time it did operate in a one-touch mode and while moving.  So, something must have been altered someplace.  I wonder if it is a hack with no hardware involved.  Very strange.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.