Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)
Sign in to follow this  
myturbo

rear spoiler failure

Recommended Posts

my 04 tt gets a spoiler fail light that goes on when it is supposed to retract after slowing down.  I can retract it with the switch though.  The dash light stays on.  Any thoughts about where to start looking?

Share this post


Link to post
Share on other sites

Does it function properly otherwise ? I.e. Go up on its own when you hit the proper speed and retract when you slow down?

Raise and lower when you press the button? If that's the case it's likely that it's one of the micro switches found on the passenger side ram under the snap on plastic cover. My spoiler wouldn't function at all. The fluid was leaking and really low, i removed it and purged and refilled the fluids but I bunged up the top micro switch and now I get a warning when it raises at speed I just haven't had the time to replace it. They are very small a very easily bent so be careful if you are investigating. My spoiler functions fine otherwise,but the warning is a bit of a nuisance. My alarm triggers when it raises, if your triggers when it retracts it's probably the lower one. There are two one at the top side of the ram and one at the bottom.

Share this post


Link to post
Share on other sites

It works fine when using the switch and deploys fine when at speed.  the failure gets thrown when I decrease my speed when it tries to retract.  I usually retract it by using the switch, which operates it up or down manually just fine.  The light in the instrument cluster stays on, but the spoiler is retracted manually.

 

By ram, do you mean the two actuators that support the spoiler when deployed and retracted?

Share this post


Link to post
Share on other sites

Yes there are two hydraulic Rams that are fed from the pump housed in the rear lid under the fan housing. The pump like any hydraulic system pumps the fluid through the bottom of the ram, to extend the piston and the top or reversing flow to retract it.

Have you nticed any fluid leaking usually residing in the caps on the bottom of the rams. I would check to see if the Pistons are raising

Uniformly, same speed same pace, any binding also when the pistons are extended are there any scratches or gunk on them that would impede free movement

My system was almost bone dry with residue in the caps on the bottom of the rams, I pulled the system out added fluid and bench tested it, it works great except for the occasional warning light. I took the car to work the other day and got no warnings at all, Im still pretty certain I Need to tweak/replace the top switch though

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.