Jump to content

Server Lease Renewal/Software Licenses

Our yearly server lease, software licenses, as well as hardware operating costs, ARE due Dec 6th, 2021. Our current donations have fallen far short of the funds we need to renew. Please remember the RennTech.org community is Member supported so please consider a donation to help...  THANK YOU!

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Added Hitch, Dealer Can't Program It... HELP!


Recommended Posts

I own a 2008 Cayenne Turbo.

I purchased an OEM hitch, control module, wiring harness, and Pollack 7-pin connector for the hitch. I installed it all this past weekend, and everything seemed to go very well.

Today I took it into the local dealer to have the tow control module programmed.

They called me 3 hours later and said they were having trouble programming it. In the end, they charged me for an hour or so of labor, and said they would need more time to diagnose it.

Here is the details given about what procedure they followed:

"Program vehicle after trailer hitch was installed. Scanned vehicle. Had multiple faults in vehicle. NEC to perform handover. Would not operate. Tried several times. All negative. Was able to manually code gateway to recognize AHK. Tried to program AHK. Negative, won't program. Tried to do handover again, same issue. Faults for AHK are 2588 Coding Issue and 0532 Open Circuit. Checked fuses 1, 3, 5, 19, 41 and all have power throughout them. Will need to have more diagnosis time to further investigate issue. Vehicle still cannot perform handover and won't program AHK."

That is the full write-up from my visit. They said that they have never seen this before and that the install appeared to be done correctly (I mean, there were only 3 factory-terminated plugs to plug in, after all).

Do any of you have a clue on what the next step is to diagnose it?

They apparently tried 2 different "programmers" with new and old versions of software installed on them to no avail.

Now, they want me to bring it back in for them to start pulling panels off the car and visually inspect every circuit... At $120 per hour, with no estimate on how long they think it will take, scares the hell out of me...

Thanks in advance for your help! I really need it right now!!

-James

Edited by Camaroman469
  • Upvote 1
Link to comment
Share on other sites

  • Moderators

There is an obvious communications issue when they try to set up the control module.  Unfortunately, it is nearly impossible to even hazard a guess as to what is wrong without further diagnostics, which means an open ended search for the fault.

Link to comment
Share on other sites

There is an obvious communications issue when they try to set up the control module. Unfortunately, it is nearly impossible to even hazard a guess as to what is wrong without further diagnostics, which means an open ended search for the fault.

Thanks for the reply. I figured that it is too open-ended for a solution to be known. I guess I will just have to bite the bullet and pay for it to be dianosed. I will post an update once they figure out the issue.

In the meantime, feel free to chime in if you have any further ideas.

Thanks!

Link to comment
Share on other sites

  • 4 weeks later...
Thanks for the reply. I figured that it is too open-ended for a solution to be known. I guess I will just have to bite the bullet and pay for it to be dianosed. I will post an update once they figure out the issue.

In the meantime, feel free to chime in if you have any further ideas.

Thanks!


Curious to know what was it? I'm doing work on an 06 955 S just like this. I've never heard about this.

Sent from my SM-N920V using Tapatalk

Link to comment
Share on other sites

55 minutes ago, stagedreiaudi said:


Curious to know what was it? I'm doing work on an 06 955 S just like this. I've never heard about this.

Sent from my SM-N920V using Tapatalk
 

The technician at the dealer ended up getting it to work. What he told me is that he had to remove/strip the programming from every module, and reprogram them in reverse order. That was his first time ever trying that, but the vehicle took it on the first try. They charged me an hour's worth of labor. I'm happy with the result. Everything works flawlessly now. Good luck!

  • Upvote 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.