Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Recommended Posts

I did a search on horns and came up with alot of helpful stuff, but could not find anything on toubleshooting the wiring. Here is the story.

I bought the 04 911 c2 6spd about a month ago. Car was new with 60 miles on it. It was in the showroom for awhile and had the trunk and engine hood lights disconnected. I wonder if they disconnected the horns to prevent people from hitting the horn in the showroom?

Now Here is what I did.

1) When you press the horn pad on the wheel, the relay clicks so that circuit should be fine.

2) Checked fuse and replaced with backup fuse,no change.

3) Replaced relay with same p/n and no change.

4) Checked connections at the horns and they are there.

I know the next step is to probe the connections and need a wire diagraham for the circuit to show me terminal location and connector locations.

I find it odd that both horns on a new car would be bad, so before I pull the bumper cover I would like to pin point the problem.

Thanks,

stan

Link to post
Share on other sites
    You can remove these ads by becoming a Contributing Member.

  • Admin

Stan,

You have checked everything except the horns (and the connection at the horns). It is a simple circuit - each horn has a ground wire (brown) and the share the power wire - that is, the relay actuates both at the same time. So, if you measure the voltage at the black/yellow wire coming off the relay panel you can be assured that power is going to the horns. At that point you have no other choice than to remove the front bumper and check the horns.

Removing the front bumper is really only a 15 minute job. When you put the bumper back on just remember to not tighten the screws fully until it is aligned with the hood and fenders (sides).

Link to post
Share on other sites

Sounds like you've spent a lot of effort trying to fix it.

Just a thought:

Why not have the dealer fix it since you are covered under warranty? If you are far from a dealer, ask the sales/service people to see if disable of horn in showroom.

Link to post
Share on other sites

HORNS FIXED!!!!!!

I check voltage at the relay feed contact=Good!

I pulled the bumper cover and checked the voltage at both connecters=Good!

I could not beleive that both high and low horns on a new car could be bad all at once, but they where. Called my dealer and he gave me 2 new horns and said not a uncommon problem. Hooked them up and Bingo, both horns work.

Used the 3rd radiator instructions to pull the bumper cover and all went well.

Half the fun of owning the 911 is working on it.

Thanks,

stan

Link to post
Share on other sites

Not to negate your efforts, but this might be a good time to upgrade your horn. I found the OEM horn to be very timid, and unlikely to get the attention of, say, a truck backing into you (ask me how I know!). On the recommendation of someone on this board I bought an Italian air-horn from Griots ($39 or so) and it made a world of difference. The install should be a cinch for you by now!

Link to post
Share on other sites

That is "sound" advice! Someone backed into my 996 when I had the horns blaring, and I immediately ran out and got the Griots horn. There is no chance that someone will not notice me the next time.

Link to post
Share on other sites

Tool Pants...

Just curious who you used to do the bodywork. When I lived in the Bay Area I used Carlson in Palo Alto. Reasonably satisfied with the work but that was on my BMW.

Jim

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.