Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Recommended Posts

My car recently failed smog due to O2 Sensor and CAT was not detected by OBDII.  The Smog tech recommended that I drive 200 miles or try replacing the battery.    I confirmed my battery wasn't an issue after testing it and began my 200 mile drive.  I figure I could probably pull it off in less miles if I varied my driving with city and street.   After about 150 miles I plugged in my OBDII scanner and to my disappointment, the O2 and CAT was still not detected.   I decided to do some research and read posts from people (non Porsche owners) driving several hundred miles with no luck.   Three nights of research later, I stumbled across a solution that didn't sound too ridiculous and tried it the same night.   Sure enough, my sensors were all detected after the first try!    The next day I took my car to the Smog station and passed with no issues.

 

Here are the steps I took:

 

PREREQUISITES: 

- The car must have been off for at least 8 hours to allow the car to fully cool down before staring this procedure

- You must have a strong battery, if you need to jump start your car or have a weak battery you could lose all the sensor data and have to redo this again

- I recommend you do this test in the middle of the night or whenever there is the least amount of traffic, you'll understand why later

- Always obey all traffic rules and use your best judgement on safety while performing these steps,  this is not worth getting into an accident over!

 

 

 

STEP 1.  WARM UP THE CAR: turn on your car, while in idle turn on your heater, headlights, and rear defroster for about 5 minutes.  Do not press the gas pedal during this process.  It is not necessary to leave your heater, rear defroster, and headlights on after this step but leaving it on should not impact the results.

 

STEP 2.  CITY DRIVING: drive your car normally through the city streets for about 10 minutes while trying to maintain the speeds between 25-35 mph whenever possible but do not go over 35 mph.  Do not accelerate hard or brake hard, just drive normally and conservatively, and do not exceed too much past 3,000 RPM.  If you exceed 35 mph once it's no big deal but if you do this often this may not work and you will have to start this process over again.  I exceeded 3,000 RPM to about 3,500 RPM once or twice but it didn't impact the results but I would not take a chance.  I made slow full stops at all the stop signs and traffic lights and when I accelerated I slowly accelerated.

 

STEP 3.  FREEWAY DRIVING: accelerate normally onto the freeway and maintain speeds between 55-65 MPH for about 6 miles, I drove about 10 miles just to be safe and stayed around 60 MPH.  THE NEXT STEP IS VERY IMPORTANT AND MAY BE DIFFICULT TO FIND AN OFFRAMP TO DO THIS SAFELY.  When you exit the freeway, DO NOT HIT THE BRAKES, the car must slow to a crawl by itself.  I used the handbrake to stop the car fully when it was crawling.    I did this test at 1am in the morning during the weekday and found a long offramp that people rarely take so it was not difficult for me to do this.  After the car stopped I slowly accelerated to the next stop sign / stop light not going any faster than 35 mph or over 3,000 RPM.

 

STEP 4.  MORE CITY DRIVING:  I followed the exact same steps as step 2.  After I was done, I pulled the car over and let the car idle for about 2 minutes before plugging in my OBDII scanner.  All my sensors came up.  

 

 

My biggest challenge was to figure out which roads / freeways I would take in order to pull this off but doing this in the middle of the night definitely helps out a lot.   My second biggest challenge was to get over being embarrassed as drivers stare you down for going well below speed limit in a Porsche.  =)   

 

There are plenty of posts out there that suggest you should maintain 25-35 mph for a solid 3-5 minutes without stopping, I thought that was absolutely ridiculous.  If that was the case, there would be a lot of people with sensors in the not ready state!

 

 

 

Link to post
Share on other sites
    You can remove these ads by becoming a Contributing Member.

  • Moderators

I think you are confusing an I/M Readiness test failure for a different type of fault.  You would get an I/M Readiness test fail if you had cleared all codes or disconnected the battery prior to going for the test.  In that case, you may have to drive for as much as a couple hundred miles before all the flags would clear, particularly the secondary air injection system.

 

If you have an O2 sensor fault (aged out, no communications, wiring short, etc.), that is not going to go away until the issue is fixed.  You could drive it until Hell freezes over, and the car would still fail.  Have you gotten a CEL, or read an actual fault code in the system?

Link to post
Share on other sites

JFP, you are correct that I am referring to the I/M Readiness.   I don't drive my car very often so at times I will have to recharge my battery in order to start the car.  I did not get a CEL, the cause was due to a drained battery.

 

You are correct that the common solution to get the sensors to a ready state is to drive several hundred miles however my solution is for people that don't want to drive several hundred miles.  This solution worked well for me without needing to drive several hundred miles, the end result was that I was able to pass Smog with flying colors.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.