Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)
incognico

996 cluster wiring diagram required

Recommended Posts

Hi all,

 

I am hoping somebody here can assist. We are looking to use a 996 cluster in a customized kit-car build. For those interested, the car is one of these.

 

The cluster donor vehicle - 2003 3.6L auto, VIN: WP0ZZZ99Z3S605556

Cluster has this on the back: VDO 110.080.019/088  -  996.641.226.01 70C

 

Any pinout information for this cluster would be much appreciated. I have done a lot of searching but the docs I've found have only had the blue connector pinouts for some reason. I'd rather not have to reverse engineer all the pins if I can avoid it :blink:

 

(Yes, I realize I will need to generate all the expected signals to drive the cluster!)

 

Thanks in advance for any help,

 

--Nick

 

Share this post


Link to post
Share on other sites

I managed to locate some connector assignment docs for the cluster and have made some good progress in getting it up and running.

 

I needed to provide (simulated for now) inputs for the various signals/sensors so it didn't throw warnings. The fuel gauge, idiot lights, etc are all working fine, as is the menu navigation. Next I will feed it the CAN [Drive] signals for the speedo/tacho/engine temp/etc.

 

I am working with limited information though, so I'd still be keen on a full wiring diagram if anyone had access to it.

Share this post


Link to post
Share on other sites

Ok, I managed to track down the relevant wiring diagrams, which is certainly making things a lot easier!

 

Thanks to all you guys for reading my post, much appreciated.

 

I will resurrect this thread with some pics for you when the cluster is installed & working, and the car's rolling :cool:

Share this post


Link to post
Share on other sites
On 11/10/2016 at 2:35 AM, incognico said:

Ok, I managed to track down the relevant wiring diagrams, which is certainly making things a lot easier!

 

Thanks to all you guys for reading my post, much appreciated.

 

I will resurrect this thread with some pics for you when the cluster is installed & working, and the car's rolling :cool:

 

Incognico, sorry for not getting back to your more promptly. I've attached the wiring diagrams. The instrument cluster is on sheet 3. I'm curious to how you are simulating canbus signals.

 

Edited by Loren
copyrighted materail removed - per site rules

Share this post


Link to post
Share on other sites
On 10/11/2016 at 10:35 AM, incognico said:

Ok, I managed to track down the relevant wiring diagrams, which is certainly making things a lot easier!

 

Thanks to all you guys for reading my post, much appreciated.

 

I will resurrect this thread with some pics for you when the cluster is installed & working, and the car's rolling :cool:

 

Hopefully you are putting a Porsche engine in it too.....

If so, a build thread would be nice to see.

Share this post


Link to post
Share on other sites
On 13/11/2016 at 1:40 AM, Richard Hamilton said:

Hopefully you are putting a Porsche engine in it too.....

Sorry, no - it has an LSA (supercharged 6.2L V8) mated to a Lambo 'box. Also, to fess up, I have no ownership in this project - it is a good friend's and I am doing as much as I can to assist... as it's pretty **** cool. My project is a plane, but that doesn't have a Porsche engine either ;)

 

On 12/11/2016 at 4:48 AM, aureliusmaxed said:

I'm curious to how you are simulating canbus signals.

On the bench I'm using an Arduino with a CAN-BUS shield. The actual in-vehicle solution is custom, with an ARM Cortex-M4 running a number of CAN transceivers.

 

All of the gauges on the 996 cluster are operating from emulated signals on the bench at this stage. I still have some gauge calibration to finish and a couple of error messages to mop up, but overall it is going great.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.