Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)
Doug_B_928

Assistance with diagnostic trouble codes

Recommended Posts

12 hours ago, Doug_B_928 said:

Update:  I took the car to the dealer a week and a half ago.  It had finally thrown a CEL and valve lift codes had returned along with a couple of misfire codes.  They were a bit bewildered.  They did find two injectors leaking and want me to authorize 8 new injectors.  They said there is a TSB on the injectors.  I'm wondering why change them all if only two are leaking.  Their technical advisor is saying that the leaking fuel injectors could cause the valve lift fault, but they can't be sure.

I'm very sceptical that the leaky injectors are the cause, not saying they aren't leaking, no harm in pushing them for the tsb if it free. 

Have your tried to flush your oil? There is another method, it's old school and involves adding atf fluid to your oil for some km and then doing oil change and filter. The atf has the same kind of cleaning effect as engine flush. 

Probably safer to go for the liqui moly though as we are not in the 1950/60's now. 

 

Are they confident the hpfp isn't faulty and cylinder 3 is the first to feel the effects? I know it doesn't make sense but a lot of thing don't on these cars. 

Share this post


Link to post
Share on other sites
    You can remove these ads by becoming a Contributing Member.

Me too.  But they know cylinders 2 and 6 have leaking injectors.  They are charging me for the injectors and labour, which is why I'm sceptical about changing all 8; especially since I also highly doubt that this is responsible for the codes and rough idle.  I suggested that they replace 3 injectors (cylinder 1 is also suspect; I'll probably end up having all 8 done so that they'll be known to be good) and when the intake is off we should be able to manually inspect how much the intake valves open (set each cylinder in turn to TDC on exhaust stroke and then observe how much the valves open on intake stroke).  If it's a stuck lifter (which in this case would be stuck in the high lift position) we should see one or more valves open further than the rest).  I haven't heard back from them since I made that suggestion so I guess they are thinking about it.  

Share this post


Link to post
Share on other sites

Yep, and, if the injectors (which I am still awaiting) don't fix it (unlikely) then the problem is probably one or more lifters stuck in the high lift position.  BTW, where is the best place to get new lifters for a 2008 Cayenne S?  I'm not finding them at the usual online suppliers (Pelican, ECS, Suncoast, Autopartsway). 

Share this post


Link to post
Share on other sites

Update:  All 8 injectors have been replaced.  I've put over 300 kms on the car and it is idling perfectly.  So, it would appear at this point that the injectors were, indeed, the issue.... time will tell for sure, but so far so god :).

Share this post


Link to post
Share on other sites
12 hours ago, Doug_B_928 said:

Update:  All 8 injectors have been replaced.  I've put over 300 kms on the car and it is idling perfectly.  So, it would appear at this point that the injectors were, indeed, the issue.... time will tell for sure, but so far so god :).

Well that's great news!

I will be having mine ultrasonically cleaned as now the plan to sell off quick has changed and fixing up to top condition is the way I'm going to demand top dollar in a private sale bitting the bullet on more costs. 

I expect I will make the car perfect and sell it to someone who really gets a great car with no issues. But hey live and learn 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.