Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)
FHS72

PIWIS 2 coding PCM 2.1

Recommended Posts

Hi to All, i'm trying to code the replaced PCM2.1 on my Porsche Cayenne turbo 04 with PIWIS, It have a VIN number different than the cars one. All is working, but all modules need updates (amplifier, telephone, cd changer), software ver. 4.1. I don't have the cds...I'm trying to change the PCM VIN to the vehicle's VIN as i have the IPAS codes. When i'm trying to code it an error message displaying! Is it possible that i'm doing it wrong, or it could not be changed? I appreciate any help.

Share this post


Link to post
Share on other sites

An 04 Cayenne should have PCM2.0, so it might be something else in the system preventing it from changing the VIN in the PCM. I guess the 2.1 must have been retrofitted.

  • Upvote 2

Share this post


Link to post
Share on other sites

Certainly what Richard said is a possibility.

My experience with PIWIS and (it's predecessor PST2) was that when replacing control modules you first had to read out the settings (from the old control module) into the PIWIS - then transfer those setting to the new control module.

  • Upvote 1

Share this post


Link to post
Share on other sites

Thank You for the information, I've read somewhere that we should read out the settings from old module as Loren said, but mine was broken.. So the only solution is to get IPAS for the PCM VIN to get access to the options. The option that I'm looking for was the compass on the instrument clusters. is there other way to have this option? Thank You

Share this post


Link to post
Share on other sites

Can you just clarify exactly what you have done?  I am reading this assuming that you have removed the old PCM2.0 head unit, and retrofitted a PCM2.1 from a MY2005+ Cayenne, along with retrofitting the DVD navigation drive.  I wouldn't get hung up about trying to change the VIN in the PCM coding - I don't think it would make any difference.  I don't know how intelligent the system is, but your VIN would be out of range anyway.

I think you need to focus on making sure all the modules are coded correctly.  The components of PCM2.1 are coded in the vehicle's Gateway module, and I am not sure that the Gateway module of your 2004 car would have the coding options for a 2005 PCM.

Share this post


Link to post
Share on other sites

Richard thats exactly what i've done, but without the DVD. I coded all modules, The only thing that i couldn't find is the update cds, an exclamation mark appear on amp, tel. and cd changer they have different firmware.

Share this post


Link to post
Share on other sites

I assume you have coded the Gateway to remove Navigation, because you need to do that if you haven't got the DVD navigation drive.  That being the case, I expect that is why the compass feature isn't working.

What are the "Actual Software" versions (firmware versions) of the units you have installed?  The Actual Software versions will be different from each other anyway.  If it is a Bose amp, and it is working, it would be dangerous to try to update it with the update CDs.  It can brick it.

If you aren't using the navigation module, then there is little point in updating the system.  You only have to do it to use the latest maps.  I have a set of update CDs, but the update process depends on the software levels of the installed components.  Also note that early PCM units can't be updated to 4.1 anyway - there are hardware differences which prevent it.

Share this post


Link to post
Share on other sites

The software version is 4.1, bose system. Navigation still installed, I didn't coded to remove it! Will try to have some pictures and wil post them. Thank You

Share this post


Link to post
Share on other sites

I find it very strange that there is a tick by the navigation software, and that values are shown, because you don't have the navigation drive installed.  The amp, CDC, and phone modules are from your old PCM2.0 system, so that probably explains the warning triangles.

I think it would be risky trying to update  those 3 modules, and you won't get any increased functionality.  If it works, then I would be tempted to leave well alone.  Many people experience the warning triangles, without having problems, and just ignore them.  The update disks are all for software 1.0 to 3.0 so I don't think they would work anyway, or might even downgrade the PCM main unit.  I can let you have them, but it would be entirely at your own risk.  PM me your email address if you want them.

Share this post


Link to post
Share on other sites

I forgot to say that from the old unit I pulled out the module from the slot, but I can't remember its a navi module or something else! and i plugged it into the new one. About updates can i try to update every unit separately?


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

I sent you an email.  You can modify the update CDs so that they only update the modules you need - I sent some instructions.

Share this post


Link to post
Share on other sites

Thank You Very Much Richard. I appreciate Your Help.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.