Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)
Sign in to follow this  
8202632

Compass Dash Display resolved (I think)

Recommended Posts

2009 Cayenne Turbo S

Ok. Here's what has been my issue. At completely random times after startup, the compass display next to the left of the on board computer would be blank. Everything on PCM 3.0 would be fine. 

So I tried to look under the rear right seat where the compass module was supposed to reside. All I could find though was a silver colored box that was confirmed to be the pdcc regulator. 

So I looked at the fuses and found fuse 36 in the right hand fuse box. It's a 5A fuse and the description is "roof module, telephone, compass."  Just for the heck of it I pulled the fuse to see what would happen. All I can tell is ever since I have done that, my compass has been showing up every single time, and I have has no loss of functionality with the roof console and/or phone. 

NO clue why this might be the solution, but the dealer replaced the instrument cluster about a year ago to fix the problem, but to no avail. I wonder what this fuse is for and if it was causing another module to interfere with the dash display?

Share this post


Link to post
Share on other sites
    You can remove these ads by becoming a Contributing Member.

So this did not work. It's continuing to disappear at random times. Anyone having this same issue?  Where is the magnetic field sensor in a 957?!?!?!?!

Share this post


Link to post
Share on other sites

OK, I've been doing extensive research on this issue. I've contacted ECS, Pelican, Suncoast, etc to figure out where the magnetic field sensor is on my car. No one seemed to know. My dealer said they would get back to me, but never heard back from them. If you look at the parts diagrams, it's not clear where it is. But here is what I think is the issue.

I looked at the order guide for the 2009 Turbo S. In the listing of the options, the compass module is an OPTION only for those cars without PCM 3.0. It clearly lists it as a conflict to the PCM 3.0 option. So this leads me to believe that if an 09 or 10 has the PCM, there is not a separate compass module. The 2008, i believe, has the PCM 2.1 as an option, even though it's considered a 957. So on this model, even if it has PCM 2.1, there is still a compass option.

I believe that somehow the PCM on the 09s and 10s feeds the instrument cluster with the compass feed. So I've concluded that there must be an issue within my PCM (or the wiring) that sends the info.

Most of us obviously do not have a PIWIS readily available, so i don't know what I can do from here. Been toying with getting a map upgrade so I can update my 1.40 software, but have read mixed things about the upside vs downside of doing this upgrade, as it could create more problems. And it begs the question as to why I even have a fuse in the 36 spot stated above. Frustrating.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.