Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Recommended Posts

There is a problem with my front hood switch / contact.

 

The light is not working if you open the hood

 

On the display is no warning if the car is driving and the hood isn't closed.

 

The low oil warning light does not disappear if oil level is checked. This is in some way connected with the hood switch too.

 

Maybe somebody can route me to the right point. It's the closing mechanism itself or something else. 

 

Thank you.

 

hoodswitch.jpg

Share this post


Link to post
Share on other sites
    You can remove these ads by becoming a Contributing Member.

If the problem is the micro switch, how to get to, how to replace? Any advise is welcome. 

 

G95562423601.jpg

Share this post


Link to post
Share on other sites
On 6/28/2017 at 3:04 PM, ekstroemtj said:

If the problem is the micro switch, how to get to, how to replace? Any advise is welcome. 

 

thanks for this excellent and right-on advise;  my 2012 Porsche Panamera turbo would not continue reminding me the oil was at minimum after i added a quart;  the problem was indeed the front hood switch ... i tested it with a ohmmeter (with insulation puncturing test leads) and sure, enough, the switch was struck closed ... i squirted some electronic contact cleaner in it, waited for drying, and it started working again - it is supposed to open when hood is closed and closed when hood is open;  i jumped into the driver's seat, ignition on, and checked oil ... sure enough the message changed from minimum level to information not available now!! ... so, I expect after I drive it a bit (10km) and check again, it will thank me for adding a quart - THANKS AGAIN FOR THE HELP! ... I had begun thinking about draining all the oil just to get a measurement!

 

hopefully this helps somebody.

On 6/28/2017 at 3:04 PM, ekstroemtj said:

 

G95562423601.jpg

 

Share this post


Link to post
Share on other sites

thanks for this excellent and right-on advise;  my 2012 Porsche Panamera turbo would not continue reminding me the oil was at minimum after i added a quart;  the problem was indeed the front hood switch ... i tested it with a ohmmeter (with insulation puncturing test leads) and sure, enough, the switch was struck closed ... i squirted some electronic contact cleaner in it, waited for drying, and it started working again - it is supposed to open when hood is closed and closed when hood is open;  i jumped into the driver's seat, ignition on, and checked oil ... sure enough the message changed from minimum level to information not available now!! ... so, I expect after I drive it a bit (10km) and check again, it will thank me for adding a quart - THANKS AGAIN FOR THE HELP! ... I had begun thinking about draining all the oil just to get a measurement!

 

hopefully this helps somebody.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.