Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Recommended Posts

X-posting from other forums as this seems to be a rare issue? 

 

Car is 2010, C2, PDK

 

Has anyone had this issue? 

 

I have read a post or two where people were just leaving things be. 

 

Would appreciate getting any feedback on what could be the cause. I have checked the power steering fluid, and it was full. 
 

The video is of the rack itself. 

 

 

 

Thanks!

Share this post


Link to post
Share on other sites

Had same problem

Rack pinion seal has had dirt/water ingress which has damaged it

Rack was replaced

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Pkcayenne
      Hi all I’ve been fighting with the cayenne again 
      let’s me put the key in and turn it then I get steering fault as attached any ideas of a way around this or a reset thanks car won’t start 
       
       

    • By Pkcayenne
      Hi cayenne 04 CTT weirdness the below list of functions was intermittent now nothing works 
       
      buttons on steering wheel 
      tiptromic button on steering wheel 
      wipers
      cruise control 
      pin out adjustment 
       
      all functionality on the steering wheel except it steers perfectly all fuses are good errors as attached any ideas was intermittent

    • By nwGTS
      I am wiring indicators, horn and brights (for flash) to an OMP steering wheel hub with buttons to my 2012 997.2 GTS.  I need the wire diagram of the indicators and brights on the steering column so I know which wires to tap (horn is done already).
       
      Does anyone have this diagram or know where I can find it?
       
       
      Edit: Looks like i need the wire diagram for these two specific parts,1 and 3 in the embedded image.  3 is the switch would probably be the one I want.  1 is the control unit and would be helpful to have but redundant if I have 3 and I probably need 3 anyway in order to test any wiring done on 1.

    • By jgiles_2
      Hi all
      My 2002 996 coupe has a squeaking passenger seat when I push/pull the top or back part of the seat, including driving over bumps.  I have half powered seats,,, the top/back is powered while the lower seat assembly is manual.  The squeak happens when the top/back is in any position including up so you can access the back seats.
       
      Something must be loose, but my question is if there are any DIY instructions that I could focus on instead of trying to tighten every bolt and hex screw that I can access.  It's pretty compact down there...
       
      Appreciated... 
       
      Thank you in advance
    • By 2lflat4
      The vehicle is a 2005 997 Carrera 3.6. I cannot find the part #'s for the 3 power steering pump mounting bolts. They are exposed after removing the power steering pump pulley. In the attached picture you will see 3 holes in an upside down U shape behind the triangular pulley mount. I tried my local dealer without any luck.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.