Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)
britdave

High revs, on cold start & Tranny holding high revs, after letting off throttle? ??

Recommended Posts

A few months ago, after having a 996 for years, I bought a slightly used 2017 911/991 gen 2 , with just 2,100 miles on it. The car is great, but I was wondering about a few things, since this is my first "automatic transmission" 911 ?
First off, on a dead cold start, the engine revs way up (something that I know is NOT a good thing for a cold engine nono.gif) and will hold the higher revs (2000-2500 RPM approximately ) for about 15-20 seconds before going to about 750 rpm, is this normal ?confused.gif

The other thing is when I nail it,'put my foot down , accelerate, the engine holds the lower gear, and high rpm , for a few seconds, AFTER I  get off (let off) the throttle, and it holds the gear, and keeps the RPMs high, it takes a few seconds to come back down, is this also normal ?  confused.gif
Perhaps it is supposed to do this, so it might sound dumb on my part ? Holding the higher rpms/ hence lower gear , for a few seconds, after I let off the throttle just seems abnormal, why doesn't it shift to a higher gear and lower rpms right away   ?  And why should the rpms go so high on dead cold start, a few days after the last time I started it ? As I know , initial start up high revs are not good. frown.gif
Thanks for any advice on this issue, cheers Dave 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.