Jump to content
×
×

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Recommended Posts

I've juIt spent £900 trying to turn off the engine check light new lambda sensors new, maf sensor ,new crankcase breather,now I've been told it could be the secondary air vaccum any suggestions 

Share this post


Link to post
Share on other sites
    You can remove these ads by becoming a Contributing Member.

Do you know what the error codes are/were? There are 500+ error codes that can trip the CEL so we will need some clue.

Share this post


Link to post
Share on other sites

The lamda sensors are p0134,p0154 but I don't know the codes for the secondary air vaccum but on my diagnostic it says not passed if that's any help.

Share this post


Link to post
Share on other sites
8 minutes ago, Derek Pallet said:

The lamda sensors are p0134,p0154 but I don't know the codes for the secondary air vaccum but on my diagnostic it says not passed if that's any help.

 

Welcome to RennTech :welcomeani:

 

Both codes are for the interruption of the  sensor signal, which is more often a wiring harness issue rather than a bad sensor.  The diagnostic trees for both codes start with checking the wiring harness, not replacing the sensors.

Share this post


Link to post
Share on other sites

They were checked by a porsche fitter when I had the work done he said the wiring seems ok he used 2 of his own to check them 

Share this post


Link to post
Share on other sites
Posted (edited)

Now saw that you are new member, welcome to Renntech!

 

I only have the 996 diagnostic info but I think they are the same for Boxsters.

P0134 is Bank 1 O2 sensor interruption of signal

P0154 is bank 2 O2 sensor interruption of signal

 

"Not passed" may not mean fail. After the DME has been reset, you need a few drive cycles for all these emission readiness flags to be set. For the SAI readiness to pass, I think the DME needs to verify the SAI at cold start and also when engine is already running. It's possible that you just haven't driven the car long enough for the DME to perform those tests.

 

Are those the only current codes? If there are no other codes, the DME Is not currently complaining about the SAI. Also, there are cases that required many miles of driving before the SAI is set, despite no issues with the SAI system.

Edited by Ahsai

Share this post


Link to post
Share on other sites

The car is also running very rich I also can't hear any noise from th secondary air vaccum on startup

3 minutes ago, Ahsai said:

Now saw that you are new member, welcome to Renntech!

 

I only have the 996 diagnostic info but I think they are the same for Boxsters.

P0134 is Bank 1 O2 sensor interruption of signal

P0154 is bank 2 O2 sensor interruption of signal

 

"Not passed" may not mean fail. After the DME has been reset, you need a few drive cycles for all these emission readiness flags to be set. For the SAI readiness to pass, I think the DME needs to verify the SAI at cold start and also when engine is already running. It's possible that you just haven't driven the car long enough for the DME to perform those tests.

 

Is the CEL currently ON and if so, can your scanner read the current error codes?

I am not in the car at the moment but will get back to you tomorrow afternoon when I have tried the diagnosis again 

Share this post


Link to post
Share on other sites
8 minutes ago, Derek Pallet said:

They were checked by a porsche fitter when I had the work done he said the wiring seems ok he used 2 of his own to check them 

 

Sounds like he checked the sensor wiring, he needed to check the wires from the sensor going to the DME as well as the out put voltages and voltage curves.

Share this post


Link to post
Share on other sites
3 hours ago, Derek Pallet said:

I believe he used an ultrasound to check the wiring 

 

I have absolutely no idea what you are talking about.  Wiring is tested using a digital multimeter looking at continuity, resistance, and voltage readings.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By osamabatrikhi
      Hi,
       
      I have the following codes on my cayenne V6, P0491 & P0492 (Secondary air injection System insufficient flow bank 1 & 2 ), I have checked the Pips ,the relay and the fuse, all are OK, the pump has no sound unless when I touch it i feel something like rattle.
       
      should i replace the pump?  
      what are the symptoms and impacts of bad secondary air pump? does affect the performance of the car?
       
       
       
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.