Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)
MTWD

PSM flashing and P0234 overboost code

Recommended Posts

Posted (edited)

Hey everyone. Relatively new to the P-car world and I've been reading through a lot of great info on here to try learn a little more about this amazing machine I now love so much. I recently developed a problem of my own and I'm really hoping for some direction from some of the knowledgeable posters here. I have a 2004 X50 Cab with a few goodies added. It's tuned and has full Fabspeed exhaust and the high flow intake and a few others. The dyno says I'm making about 570 hp and it's a blast to drive. I'm running 1.1 bar of boost normally, but recently I started getting what I first thought was a miss from a bad coil pack at about 4400 RPM under hard acceleration. The odd thing to me is that I'd get a couple of flashes from the PSM light too. I checked the codes last night and was surprised to find that I'm getting a P0234 overboost code, rather than a miss code like I had expected. That was the only code showing, so I reset it and took the car for a drive. Having been given the overboost code I watched my boost much more closely and sure enough, under hard acceleration I did briefly hit 1.3 BAR. From what I've been reading, I'm maybe looking at a waste gate actuator or something to that effect? Anyone out there that can offer me a little advice or point me toward a good independent Porsche mechanic in the central WI area?

Edited by MTWD

Share this post


Link to post
Share on other sites
    You can remove these ads by becoming a Contributing Member.

OK, so I'm getting this figured out little by little. The flashing light I'm guessing is just a symptom of the overboost. . I checked the vacuum lines up top this morning and didn't see any issues, so I got underneath to see what I could see and to try actuating the wastegates by hand. The driver's side I can actuate normally. On the passenger side the actuator rod was rubbing against the one flange it runs past and judging by the wear it has been that way for a while. I adjusted it away a bit, but that wastegate won't open. I'm thinking the movement has been restricted and has either damaged the actuator or the wastegate. my thought is to disconnect the actuator rod and see if the wastegate will move then. Anyone have thoughts on whether the actuator failing would somehow cause it to "stick" shut?

Share this post


Link to post
Share on other sites

PB Blaster and a 17mm wrench on the wastegate arm and gradually worked it back and forth to get some movement. Car is warming up and we'll see....

  • Upvote 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.