Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Cabriolet Top/Clutch Pedal


Recommended Posts

Two issues with my TT Cab:

The top started squeaking horribly today - at all speeds/road conditions. The car has about 700 miles and it's the first I've noticed it. I had this problem on a '99, but not on the '01 and '03 and thought it had been fixed by Porsche.

The problem only occurs while the top is up. It sounds as if it is metal on metal and I'm wondering if it has something to do with the metal boot cover rubbing against the top components. Are there any TSBs or other solutions for this problem.

The second issue I have is with a squeaking clutch. It only occurs during the last 1/3 or so of engagement. I've read about this problem before. Is there a simple fix or is this a dealer fix?

TIA,

Eric

Link to post
Share on other sites
    You can remove these ads by becoming a Contributing Member.

Just did a test on the top. I pushed on the soft top and was able to duplicate the sound on both sides of the car. It appears as if the squeaking is being caused by the roof rubbing against the metal boot. I put the top down and then back up and the sound is now gone. It will probably reappear once I go over some bumps/heaves in the road the next time I drive.

Link to post
Share on other sites
  • 4 weeks later...
  • 1 month later...

How about the clutch squeek??? Do you still hear the sound???

Mine squeeks a bit, but now I've noticed the clutch feels kind of spongy when I press the clutch quickly...I checked the hydraulic fluid and it was very low. I topped it off with the "11 S" stuff from the dealer and it's better but not quite like before. Any ideas???

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.