Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Recommended Posts

Hi all, just purchased a 1961 notchback 1600s, I have never drove a Porsche until the day I purchased this car, got the bug now and i love Porsches more than ever now, the car is in very good shape, but i want to change all the fluids, grease all the parts, and do all the maintenance there is, the oil was so dark when I checked the level and it was all the way to max line of the stick, i would appreciate if you guys can tell me where to buy all the maintenance parts, and where can I buy the shop manual, and what are the things I should do, there is a small leak on the floor from engine very small, but a palm size of oil from transmission on the ground,  thanks guys cheers😁

srgergered.jpg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By Garra671
      Recently I had been noticing issues with my cooling system the coolant temp guage would go past the 0 on 180 and I wouldn’t hear fans or anything. (Already tested fans and resistors and relays).   The temperature Will continue to creep up if I sit still, with no signs of fans, AC OFF.

      I replaced the coolant temp sensor. Problem fixed!! Then same issue again it seems after a week of driving.  

      Now i currently have ordered another temp sensor just Incase I maybe did something to cause the other new one too fail, I’ll be changing it again today.

      However I was doing the climate control hack to check my actual temperatures today while doing a short troubleshooting drive. And I noticed my oil temperature said 0, which is physically impossible 🙄


      Is it possible the oil temp guage is throwing off the coolant sensor?    Is it even possible for the oil temp sensor too go bad but not the oil level sensor? (They are a 2 in 1 sensor)   

      THANK YOU IN ADVANCE
    • By salamander
      I have a 2007 C2S manual with about 132K on the odometer.  A low oil pressure light has started to show up at idle after the car is warmed up.  It seems as if the light is gradually coming on more frequently.  The pressure gage on the dash reads around 0.5 bar when the light comes on.  When the car is cold the starting pressure is around five bar and is about 3 bar at 3000rpm.  As it warms up the pressure drops to about 2 bar at 3000rpm.  I always run 0-40W Mobil 1 and change the oil every 5K miles.  With the engine off and turning the key one click the pressure gage rises to about 0.1-0.2 bar.
       
      Can anyone help me diagnose this issue?  Would be a sensor or something mechanical?
       
       
    • By gary_cs
      The left door key switch on my 00’ 996 c4 will not lock or unlock. I took the handle and bracket out of the door frame. I was told what usually breaks is the cylinder but nothing appears to be broken. I don’t want to buy a new key so simply replacing the bracket isn’t an option. Is there a straight forward solution or do I need a specialist??
       
      Any my feedback would be much appreciated thanks!
       
    • By Nicky_Noodle
      I have a 2004 Cayenne S. I just got it recently, interior lights have never worked. I checked the fuse and it was blown. It calls for a 20 amp fuse but the blown one in it was a 25 amp. I had the key in the ignition if I remember correctly and put the new 20 amp fuse in and everything came on. Side note, I noticed a weird glitch with the light above the rear passenger side door and the switch on the main map reading light. The interior lights had gone off and I turned the back on and the backlight above to passenger side door was very dim. I slid the switch on the overhead console for the main map light and the rear light came back to full strength. I found that odd. Everything then worked fine. I took the key out. Next time I put the key in, immediately heard the fuse blow. Any ideas on where to start?
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.