Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Recommended Posts

I got in my '03 CTT this morning and it would not start.  I put the key in, got the normal lights and sounds and the starter wouldn't turn over at all.  I can hear what I assume are the battery relays.  Both batteries are fairly new, but I charged anyway, same result; tried to jump start, same result.  I drove the car yesterday and no issues.  The starter has been working perfectly, no dragging, or slow starts at all.  Does this sound like the starter? Has anyone had the starter go bad suddenly with no prior warning?  Any suggestions would be greatly appreciated before I have it towed to the shop.

Link to post
Share on other sites
    You can remove these ads by becoming a Contributing Member.

  • Admin

"If two batteries are fitted to the vehicle (main battery and backup battery), these are connected or disconnected to the bus bar in the power distributor through a relay. The switching of the two batteries is controlled independent of the load management (function is integrated in the vehicle electrical system control unit). The starter relay of the 2nd battery is actuated parallel to the starter relay. That means for every start the starter is supplied from both batteries. The backup battery is disconnected from the vehicle electrical system when the engine is switched off and then supplies just one consumer, the vehicle electrical system control unit."

 

Unless those old batteries have been load tested there is no way to know if they can handle starter loads.

I would still get at least one new battery and give it a try.

  • Upvote 1
Link to post
Share on other sites
  • 2 weeks later...

FIXED! I had to take it to my mechanic and he was puzzled after both batteries tested fine and removing the starter and it bench tested fine.  Ultimately, he cleaned and tightened the power connection at the starter and the connection at the power distribution box and this fixed the problem.  There was some corrosion on the starter connection and this connection came from the factory without a lock washer and wasn't completely tight.  It did last 17 years, though.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.