Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Recommended Posts

I went through the process of switching out the OEM shifter with an OEM short shifter. Of course this required removing the center console to get the old shifter. To remove the center console, I removed the connector that is attached under the front center console.  Put the short shifter in. Before putting the center console back in, my friend took it for a spin around the neighborhood to make sure no adjustments were needed. Felt great. Put all the parts back together then the wife took it for a drive. In both cases no one noticed the airbag light on at that time. The following day, I took for a short drive to see how it felt. That's when I noticed the airbag light on in the console.

 

Can anyone verify that some of the wiring running through the center console controls the airbag. I'm thinking if that's true, I might need to take the center console off again and verify all wires are connected. If not then I need to look somewhere else, but where?

Link to post
Share on other sites
    You can remove these ads by becoming a Contributing Member.

  • Moderators

Welcome to RennTech :welcomeani:

There is a sensor for the air bags under the center console that measures rapid deceleration, triggering the bags.  Most likely, when the car was driven without the console reinstalled created this issue.  I would have the code read and then cleared with a Porsche specific scan tool (disconnecting the battery will not clear it, it has to be done with the correct scan tool), and then drive the car to see if it comes back.  If it does, wiring is not connected correctly; but I would be willing to bet it won't come back.

 

Good luck.😉

Link to post
Share on other sites

Hi JFP,

 

I was wondering if driving it without reconnecting the wiring was the problem. I have the iCarsoft scan tool that advertises that it can clear airbag light, but I couldn't find it. Now I'm looking at the Durametric tool (a lot more expensive).

 

Thanks,

Bruce

Link to post
Share on other sites
  • Moderators

All cars will log a fault if any airbag or seatbelt component  is disconnected and then the car is turned on or started. 
 

The good news is that the Durametric SW has the biliary to clear the fault. 
 

the moral of the story is that if any airbag or seatbelt component is disconnected, don’t turn on or start the car until they are reconnected. 👍🏻

Link to post
Share on other sites

May take a couple of days to get to you 😀

 

Just received email from Durametric. Their software only works with models up to 2015. So my 2016 and 2018 will not work. Of course they say they're working on it, but have no timeline.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.