Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)
Jeff_C

Antenna Booster (or poor radio reception)

Recommended Posts

Can someone please tell me why I should have almost non-existent radio reception? All I've been able to find is some vague reference to a bad ground but no details. Is this bad ground on the booster itself or the radio? And, what does it mean if I disconnect the power from the booster and the reception improves (slighty)? Does this indicate a bad booster?

TIA for any insights anyone wishes to share.

Jeff

Share this post


Link to post
Share on other sites
    You can remove these ads by becoming a Contributing Member.

Well Jeff why don't you tell us about your car...like what is it? There are TSBs for poor radio reception. So check there as well.

Edited by wross996TT

Share this post


Link to post
Share on other sites

How embarassing. I thought i had all that info in my signature. :oops:

Anyway, as it says I have an '01 with the HiFi option (no MOST). When I got the cat it had the stock headunit CDR220(?) and almost no reception (and terrible sound through the CD). I wanted an iPod interface so I swapped out the hu for an Alpine and the reception (of course) didn't improve :cursing: but it sounds much better when using the CD and iPod (speakers and amp are next).

Sometime though it is nice to be able to listen to weather report (especially with a Cab :D )

BTW, I did check the TSBs but didn't find anything. Of course I may have been searching improperly (wrong terms) as I am new to the TSBs.

Thanks for any help you can provide.

Jeff

Share this post


Link to post
Share on other sites

Some thoughts.

If the windshield has been replaced the antenna may not have been hooked up.

Some people have tried improving the ground for the booster, by removing it, sanding the metal, and putting it back in.

I guess the booster could be bad or it is not getting power.

See if you can try another 996 in the same area and if that car has the same issue.

Share this post


Link to post
Share on other sites

Do you have anything plugged into the cig lighter? Mine did the same thing with a radar detector, when I unpluged it, problem gone. Wireless detectors for me!

Share this post


Link to post
Share on other sites

Thanks for the input guys. The TBS doesnt help a whole lot as it basically seems to do a diagnostic before replacing the antenna booster.

I am going to try the sanding method and removal of my cellphone charger next.

If anyone has any other ideas, I'm all ears.

Jeff

Do you have anything plugged into the cig lighter? Mine did the same thing with a radar detector, when I unpluged it, problem gone. Wireless detectors for me!

Oh, and Chris, I'm still loving those GHL Louds especially with the K&N CAI :)

Jeff

Share this post


Link to post
Share on other sites
Thanks for the input guys. The TBS doesnt help a whole lot as it basically seems to do a diagnostic before replacing the antenna booster.

I am going to try the sanding method and removal of my cellphone charger next.

If anyone has any other ideas, I'm all ears.

Jeff

Do you have anything plugged into the cig lighter? Mine did the same thing with a radar detector, when I unpluged it, problem gone. Wireless detectors for me!

Oh, and Chris, I'm still loving those GHL Louds especially with the K&N CAI :)

Jeff

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.