Jump to content
×
×

 

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

nasocbr

Members
  • Content count

    2
  • Donations

    $0.00 
  • Joined

  • Last visited

About nasocbr

  • Rank
    Member

Profile Fields

  • From
    Bulgaria
  • Porsche Club
    Other
  • Present cars
    Porsche Cayenne S 4.8 2008
  1. Hi Same situation here. Was it the HPFP?
  2. Hi, I have the same problems with the HPFP. All began with 10sec long cranking cold starts and sometimes loss of power when accelerating during highway driving. Then cold starts became harder and once engine was started it was shaking like misfire. Pushing the throttle to 2000rpm for few seconds was solving the problem. On a highway run there was knocking and shaking sometimes when accelerating above 3k rpm. Monitoring the fuel rail pressure while driving showed pressure drop to 10bar and after a while returning back to normal 40-100-120bar depending on the throttle position. About 6 months later and 6000km passed HPFP totally gave up with a rail pressure 5bar (fuel supply pumps pressure) reaching 10-15bar sometimes. CEL is on showing P1021, P1023, P1026, P0431. I am using a simple OBD2 bluetooth reader with Android app. Looking for a new HPFP here in Europe I found out that there are two types: 94811031507 - brand new direct purchase and 948110315GX - refurbished, rebuild, reconditioned with exchange option. As I am planning to do it by myself following the DIY instructions on the forums I have some questions. Can you advise where you get your new HPFP from (Europe) and at what price, what part number are they. Did you remove the intake manifolds in order to replace the HPFP? Is there any adaptation needed for the new HPFP (software, OBD) or it is working straight away after installation? Did you disconnect the car battery when doing all this? Thank you
×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.