Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)
donjuan143

expert help needed

Recommended Posts

whenever i turn on the A/C, load comes into the engine and you can feel vibration on the car.

is it an engine problem? (engine cant take the A/C load) or something is wrong with the A/C ?

Share this post


Link to post
Share on other sites
    You can remove these ads by becoming a Contributing Member.

What's the engine RPM when the A/C is on? You might need to clean the throttle body/idle speed motor.

Share this post


Link to post
Share on other sites

No expert but I’ll speculate & take a stab at it. I doubt your engine is at fault. Probably not the ac pump either or you’d might be getting screeches from the belt.

AC pump puts a significant load on the motor. Mine dogs at Idle for a second when the AC is turned on but, the pops back up to a normal rpms.. I believe the AC also shuts off under heavy acceleration.

My guess is that the speed up (at dle and) cut out at heavy load circuit is amiss.

Regards, PK

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.