Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

O3C4S

Members
  • Content Count

    4
  • Donations

    $0.00 
  • Joined

  • Last visited

Community Reputation

0 Neutral

About O3C4S

  • Rank
    Member

Profile Fields

  • From
    Minnesota
  • Porsche Club
    PCA (Porsche Club of America)
  • Present cars
    2003 911 Careers 4 S
  • Former cars
    1984 944
  1. Have 03 C4S 55K mi. Both Cats going bad. getting CEL after every 50 to 75 mi. First from bank 1 and now bank 2. Have basic Torque App software to reset. Pain in Butt. I track car about 3 times a year. No car mods. Run for fun. Looking to boost HP via new performance exhaust system. Thinking Headers and Sport CATs from Fabspeed. Factory mufflers are original, seem fine and would like to reuse. Along with perhaps new clamps, gaskets and a few new bolts, does anyone have advise on this?
  2. Sorry, Way late on this reply, I rebuilt calipers with new seals and dist caps. easy fix. Piston walls and pistons were in a-one shape. cleaned and reinstalled. Good improvement, pads were relatively new so didn't change. Bleeding was simple with assist by wife on the pedal. Small quantities of bubbles when bled. I actually pre-filled calipers with fluid before installation to help minimize fluid waste and reduce air bubbles. Not sure what people think of that method but I'm anal sometimes, worked for me. Bled fronts only. Ran a weekend Road America after rebuild, worked great. Normal and even brake dust accumulation on both sides. Also had 4 wheel alignment to double check pulling. Specs were off a bit so this contributed to excellent tracking while momentary hands off steering wheel, no wandering. So I believe result was a combo of both fixes.
  3. only does while braking. brake dust on right side is slightly more than left possibly indicating problem. was going to try to bleed system. can these pistons be rebuilt or reworked or? not sure. don't want to replace if repairable.
  4. 2003 911 C4S, Intermittent brake pull to right. Brake fluid replaced. Replaced all pads, no change. Car has 55,000. Where do I go next? Sticky caliper maybe? Brake booster? Any suggestions welcomed.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.