Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

aaaron

Members
  • Content Count

    1
  • Joined

  • Last visited

Community Reputation

0 Neutral

About aaaron

  • Rank
    Member

Profile Fields

  • From
    Sydney, Australia
  • Porsche Club
    No
  • Present cars
    etype jag
    C3 corvette
    981 Cayman
  1. Hi folks. First post so bear with me. I've just completed a major mechanical rebuild of my 981 GTS. Came together well but I am having overheating problems. I've flushed and refilled the cooling system several times using a vacuum pump (and even tried pumping it up through the radiator bleed hose) but can only seem to get around 12 litres into it. I believe the capacity is around double that. I've tried opening the heater and heat exchangers valves manually to see if that's where the rest is supposed to be hiding. I've even removed the thermostat (what a neat piece of engineering) to see if there might be a blockage somewhere. I'm at my witts end... Any clues? What am I doing wrong? Suggestions please....
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.