Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Jefferson Dairy

Members
  • Content Count

    2
  • Donations

    $0.00 
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Jefferson Dairy

  • Rank
    Member

Profile Fields

  • From
    07849
  • Porsche Club
    PCA (Porsche Club of America)
  • Present cars
    Panamera Turbo
  1. Ciaka thank you for the advice. I took it to the dealer and they first replaced the valve block. That was a very long process because they said the part needed to be ordered. A month later they called and told me it was done. I picked up the car and then drove the car about 90 miles and the same “chassis system failure” message appeared. I once again took it to Porsche of Flemington, NJ and this time they said replacing the compressor would “probably” fix it. This time they only had it for 2-weeks. Lol. Ever since then it’s been fine with regards to the cars air suspension as it is functioning as it should. The complaint I still have is the banging or thumping sound the car makes when the wheel is cut all the way in one direction. It happen mostly when it’s cold. The dealer kept telling me it’s normal and all Porsche’s do it when it’s cold. I find it hard to believe a car that costs $150,000 is supposed to make such an awful noise when it’s cold. The service manager finally relented and admitted it can be fixed by replacing the lower control arm. He said there’s absolutely nothing wrong with the car and it performs as it should. He said replacing the control arms and getting it aligned would do nothing but eliminate the noise when it’s cold as well as eliminate a few thousand dollars from my pocket. He said if it was his car he would leave it and live with the noise when it’s cold because it is mechanically sound. I opted for that option because I intend to take it elsewhere. Now that I’ve researched it, I see that it’s a known problem and Porsche has addressed it in new models. I’ve always owned BMWs and Mercedes. I’ve never had any issues with them and they have always been extremely reliable. This is my first Porsche. I love it but I cringe and cross my fingers every time I start it. I’ve always heard about Porsche’s legendary reliability but my experience is more like with my ex. It’s expensive, very finicky and costs a fortune to enjoy its company. Also like my ex it’s sexy, fast and so much fun to ride. So now I face the same dilemma I did with her. Keep it and put up with the annoying and expensive upkeep for the exhilarating performance or get something reliable and sophisticated that I can live comfortably with. FML. Why a higher power hasnt figured out how to deliver both is beyond me.
  2. My Panamera Turbo displayed a “chassis system failure” message last night. Today the message is gone. It has 6,000 miles but is a 2010 so it hasn’t been used much. A few days before the message displayed I noticed there is a “bump” or shutter when turning the wheel tight at low speeds. It almost feels like I’m going over a pot hole. I’m wondering if anyone has any idea of what the issue could be. I know the suspension is pretty complex. If anyone has an idea of what the problem is or where I should start looking for the source I’d appreciate the advice. Thanks!
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.