Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

ddx77

Members
  • Content Count

    3
  • Joined

  • Last visited

Community Reputation

0 Neutral

About ddx77

  • Rank
    Member

Profile Fields

  • From
    Corvette
  • Present cars
    2012 Panamera

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Thanks, I sort of assumed it was a different horn. I will take you advice and change them out. I don’t like the sound of the factory horn anyway. Thanks again for your help! Sent from my iPhone using Tapatalk
  2. A Porsche mechanic checked them when they reinstalled one of them. It worked for about two days. It must be the wiring, I will check that myself. Thank you very much! The steering wheel has not been off to my knowledge. I bought the car with 30k on it. When I hit my lock button the horn sounds perfectly, not sure if that’s within the same system or not. Sent from my iPhone using Tapatalk
  3. My horns are intermittent, one day works, the next doesn’t. Had one horn replaced once and it didn’t help. I’m at 95k miles and thats been my only issue. I’ve learned to live with it. 2012 Base Panamera Sent from my iPhone using Tapatalk
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.