Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Carrerax

Members
  • Content Count

    1
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Carrerax

  • Rank
    Member

Profile Fields

  • Porsche Club
    PCA (Porsche Club of America)
  • Present cars
    993 X5 4.4L 540it
  • Future cars
    C$S then 456gt
  • Former cars
    E30 M3
  1. Hello all, I just bought a 1995 993 with 79k miles yesterday. The PPI was perfect with the note that the clutch pedal is a bit low and it may need a clutch sometine soon. That isnt a problem since I plan on pitting in a LW flywheel. Anyway, Since I flew to New Jersey to pick it up and I had to drive back about 600 miles I didnt beat on the car at the test drive. I did driive it but didnt go over 5k. And it runs great. So basically, Im driving back yesterday and had to go around a semi and I had to run it up to get around him (Plus I just wanted to have a little fun) and it wouldnt pull over 5k or so. The car just felt lke bad gas or something. The car has been a garage queen for the last 3 years. Anyway, I ran the car down to 1/2 tank and filled it up and it felt like it was getting better (I mean it would rev a bit higher) but not to redline. Sometimes it would get almost to 5800 but thats it. So I ran that tank out until the light was on and filled it up again for the last 100 miles of the trip (Right at Mid Ohio actually and it still wont go to redline. I got home at midnight and I love the car but I just need to figure this out!!! Help! PS, I did do a search. THanks!!! Mark
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.