Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

carldh

Members
  • Content Count

    5
  • Donations

    $0.00 
  • Joined

  • Last visited

Community Reputation

0 Neutral

About carldh

  • Rank
    Member
  • Birthday 07/02/1980

Contact Methods

  • MSN
    pnrcarl@gmail.com

Profile Information

  • Gender
    Male

Profile Fields

  • From
    Tempe, Az
  • Porsche Club
    No
  • Present cars
    04 Cayenne Turbo
    87 951
    07 Audi A3
  1. I found some mud in my CTT.... street tires are very slippery in deep mud :D I had the PSM off the whole time i was pulling doughnuts and drifting like a mad man, then i turned the PSM back on and i could feel it braking the wheels that were slipping but i was not able to go very fast cause the mud was sooo slimey that it took a lot of wheel spin to get moving.....all it good fun B)
  2. Chestah, Mine does the same thing... i live in Az an on the way home the Outside temp is about 94 degrees on the way home.... im stuck in traffic for about an hour "stop an go".... my temp gauge has got almost to the line before the red, but when i got out of traffic to "clean air" the temp dropped to 1/2 right away....i smell coolant as well when i park but the level has not dropped at all...so if this is normal i would feel a lot better...hahaha thanks, Carl
  3. I was messing around with my 04 CTT and I was able to brake torque it and launch with the boost gauge(factory) reading 0.8 bar... took off like a bat out of hell....left the trans in manual and let it shift by it self.... i would NOT do this style of "sprinted" launching a lot b/c it cant be good on the trans... but man it sure was fun....hahaha Carl
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.