Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

tdemo1

Members
  • Content Count

    3
  • Joined

  • Last visited

Community Reputation

0 Neutral

About tdemo1

  • Rank
    Member

Profile Fields

  • From
    Calgary, AB Canada
  • Porsche Club
    POC (Porsche Owners Club)
  • Present cars
    2015 Porsche Cayenne S
    2001 Porsche Boxster S
  1. Have 06 CS titanium edition. Just last week I had the same error on my system - Nav error, both amp and nav unavailable. I turned the amp off and on several times - sometimes with longer wait periods, upto about 3 minutes and still came back with the same error. Tried turning ignition off and then back on - no change. Parked my unit for the night - next day worked fine. Have not had the error since. Also should mention that I had never experienced this issue before. I will update if it happens again. It is still under warranty and I will get it looked at right away. Its not a lot of fun sitting in traffic in silence.
  2. Thanks to all of you for your valuable input. I' am trying to line up a test drive to see for myself, and I will try to keep my head about me. It seems that the CS is a tremendous vehicle and anything more is a matter of emotion - or pure exhileration!!
  3. I have a 2006.5 Cayenne S Titaninium Edition with 13000 miles and I love this SUV. I really enjoy the ride and feel that there is a lot of power!! However with the change in the economy I have seen several deals out there. Is it worth it to trade mine in for a 2006 Cayenne Turbo with 34000 miles on it? I have a few considerations: 1) Is the added power needed and/or available to use in daily driving in the city? I love to drive 'spirited', but find few opportunities in the city. 2) I will be losing about a year of warranty - should I ensure it is CPO? 3) What dollar difference would be a good deal in cost considering the mileage and loss of a year? 4) What factory options do you think are very important on the turbo? I have not driven a turbo and really value your opinions on the difference between the two. Cheers
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.