Jump to content
×
×

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Roberto

Contributing Members
  • Content Count

    19
  • Donations

    $0.00 
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Roberto

  • Rank
    Contributing Member

Profile Information

  • Gender
    Male

Profile Fields

  • From
    Miami/Montreal
  • Porsche Club
    No
  • Present cars
    1999 Porsche 911 Cabriolet
  1. Thanks...I pressed the button on teh hand brake and I get the top to close...but not completely. When the top is down, you can see a "lift" at the back, like something is not letting it totally clamp down. Could the latch at the rear where it hooks in need some WD40? Thanks again for your help Roberto
  2. Hello, I have a 1999, 966 Cab. I changed the hydraulic cylinders and verified the oil level about 6 months ago. Just recently, I lowered the top, went for a long drive and closed the top, all good. Next time I opened the top, I noticed it opened up real quick, no concerns. Problem: the red light for the top stays lit on. I them noticed at the back, it does not seem 100% closed. I can still open and close it, except I can "hear" it is open. Yesterday, I tried closing the top using the button on the inside and no luck, I had to close it using the key. Anyone had a similar issue...hopefully with a solution? Thanks & have a great day Roberto
  3. Hello, I recently purchased the following cable to connect my Ipod. http://www.discountcarstereo.com/detail.aspx?ID=1010 I disconnected the CD (blue plug), added the one on my new wire, grounded the black wire and found a power source (tapped the an orange wire) for my red wire. I then went to activate the Aux and turned this to on. Result: when I press the CD button, it says "loading", I then play my Ipod, but slowly the CD button fades out to FM radio and I don't hear my Ipod. On top of this, the wire is also supposed to be able to charge my Ipod which it does not. Does anyone see something I am doing wrong? Your help is greatly appreciated Thanks Roberto
  4. Hello PTEC...I guess you are trying to tell me to find a mechanic to install and not waste my time or get aggravated doing it on my own? Thanks
  5. Hello everyone, been for some time I have been hearing a screeching sound from my passenger window. I was told it could be the window regulators because when I would close the passenger door, the window would not go down that 1/2 inch and back up (it is a cabriolet) Yesterday, when I opened the top, I noticed the window actually only went down about 2 inches and would stop; it would not go down more than that. I tried again this morning with the top on and all it would do is go down about 2 inches and back up, nothing more, nothing less. Could this be that my window regulator finally gave away? It was an extremely hot and humid day here, I don't think that had anything to do with it, but just thought I would mention. My car is a 1999, 911 cabriolet. Thanks for the help Roberto
  6. Correct. I checked and yes, the plastic cover for the latch seems to be broken only at the end...funny how it can be removed so easily? So you suggest I pick one up and glue it back on? Thanks for you help
  7. Hello, I hope you are all enjoying the summer; what a great time to be driving a cab. I had a question if maybe someone has already experienced: my top goes down and back just great, but on the way back up, it goes well till it needs to latch and lock. The hook at the end seems to get in and then out, even if I keep my finger on the close button button. It does not happen all the time, but more lately. So to close, I get it as close as I can and then raise the windows manually, back ones being a bit trickier. I tried also closing from the door, same thing happens My cab is a 1999 Thanks for your help! Roberto
  8. Hello Simon, I am from Montreal to. Just bought a 996, 1999 in Miami, Florida. I am having it shipped up for the summer. I plan to keep Florida plates till I decide if I am coming back to Miami, but my question is: should I decide to stay in Montreal, what did they put you through to get Quebec plates? I know there are taxes to be paid: 6%, 5% and 7.5%...anything else I should know about Take care Roberto
  9. And the final result......the ignition switch! Got it fixed and had the rest of the car checked at the same time. I wish I was more "mechanically" inclined. I sometimes get intimidated by what I read but maybe pretty simple. I also wish there was a crash "Porsche mechanic" course, I think I would take it...maybe in Germany? Thanks again for your help Roberto
  10. Hello, I was wondering if anyone knows of a good Porsche mechanic in Montreal, Canada. I have a 1999, 911 and rather not go to a dealer if need be. I have a great mechanic in Miami, but I will be in Montreal for the next 3 months for the summer. I hope I don't need one, but just in case Thanks Roberto
  11. Hello Wayne, thanks for the response. It is a 1999. I actually took my "valet" key and tried that, nothing. It's like everything comes on, guages, lights...but when I turn the key, it does not even make a click. The one think that bothers me is that before it reached this point, when I would start it, it never did on the first turn on the key. I always had to re position the key and the second time it always started. I would like to tap it to at least get it to my mechanic. He has already ordered the starter, I assume by doing so I cover the ignition switch? What do you mean by "dash issue"...got me a bit worried. Where would the starter selonoid be located? Thanks for your help
  12. Thanks...it was not the starter? I have not brought it in yet, but the mechanic made it sound like a starter issue...we'll see
  13. Hi, I've had my 966 for 4 months and I have noticed that when I start it, when I would turn the ignition the first time, no luck, but the second, always was a go. It runs great. Today I took a drive, all was well. I parked. Came out 2 hours later, took the top off, put the key in the ignition, first time no luck, second time, nothing again, third time....all the lights are on, I even got a boost, no luck. There is no sound what so ever when I turn the key in the ignition. Has anyone ever had this type of problem with possible suggestions? Thanks
  14. has not set their status

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.