Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

abdulrahman

Members
  • Content Count

    1
  • Joined

  • Last visited

Community Reputation

0 Neutral

About abdulrahman

  • Rank
    Member

Profile Fields

  • From
    Kuwait
  • Porsche Club
    POC (Porsche Owners Club)
  • Present cars
    Porsche 997 Turbo 2008
  1. Hello, After I changed the tie rod end I had ABS, PTM AND PSM Failure lights and the car is completely crazy the performance is reduced and as soon as hit the gas it might spin if it was a full throttle, anyone have an idea about this issue? we checked all the sensors and tested all of them and r working fine ! 1 day later the PASM was working fine * sport absorbers * as soon as I pressed the sport absorbers to check if it is working or not, it was fine, but as soon as I turned it off I started to have one more failure PASM failure. The car is 997 Turbo 2008 Any idea guys?
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.