Jump to content

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

WhisperBlade

Contributing Members
  • Content Count

    79
  • Joined

  • Last visited

Community Reputation

0 Neutral

About WhisperBlade

  • Rank
    Contributing Member

Profile Information

  • Gender
    Male

Profile Fields

  • From
    Canada
  • Porsche Club
    Other
  • Present cars
    Porsche Cayenne S 05
  • Future cars
    Porsche Cayenne Turbo S 11

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Hello, My rear taillight has a cracked lens (chunk missing) Don't wanna pay for a new housing. Does anyone know where and if one could purchase just the lens cover? Thanks in advance. .C
  2. Hi rik, The mirror that I have is a dimmable, heated one. Would the cheap replacement glasses cut it? Thanks! .C
  3. Hello Forums, A driver in oncoming traffic swerved into my lane and rammed into my driver side mirror. The mirror bent inwards. Upon reengaging, I found that the lens had cracked, the top plastic cover had flown off and the bottom had a scratch on it. The OE Mirrors part number is - 95573104303. These are 350$. I'm not sure what my insurance deductible is but this seems outrageous for a mirror. Does anyone have a cheaper fix to this? Thanks.
  4. I have had the exact same problem with the exact same symptoms. Your CET has failed. Replace the CET. You also have air trapped in your radiator; You'll need to to vacuum your CET after your change it.
  5. I ended up having 2 of the low-pitched horns go out. I got frustrated with the process so I just unplugged the low-horn and closed the circuit. The high horn works fine now. Don't need the low anyways.
  6. I just wanted to confirm - Do I need six GALLONS of coolant? (I'm in Canada. Things are sold by the litre). In which case, I will need 11.5 Litres of Coolant + 11.5 Litres of Water? Thanks!
  7. Mihai, Do you have any recommendations on air compressor? (The Porsche one in the truck goes to 80 but I'm not sure the hoses fit?)
  8. One more question; Does anyone know that, when using the AirLift II, what PSI is needed for coolant flush? Would the factory-equipped air compressor in the trunk suffice? Thanks!
  9. And thanks a ton Mihai. I hope anyone else researching into this will get some useful tips.
  10. Thanks! I appreciate it! Does anyone know if the car needs to be lifted for a full coolant flush, or can I do it off the ground? Thanks!
  11. Diagnosed as broken coolant reservoir. Does anyone have any walkthroughs or general tips on DIY replacement? Thanks!
  12. Hi everyone, Replaced the Pipes on 05S 4 years ago. Recently, car is displaying "Check Coolant level" and coolant level is dangerously low. Last top off was only 2 - 3 weeks ago. There is no visible mark below the car of any leaks when parked in garage. I parked it outside in the cold last night and got this warming again. It's raining, and I can't verify if there's a leak. Anyone know what might be the issue? 126K KMs. About 80K Miles. I've got Water Pump from Pelican parts in my shopping cart ready to order. But since I live in Canada, I want to order anything that might be the issue all in one go. Thanks! .C
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.