Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

donmega997

Members
  • Content Count

    1
  • Joined

  • Last visited

Community Reputation

0 Neutral

About donmega997

  • Rank
    Member

Profile Fields

  • From
    Alexandria, VA
  • Porsche Club
    No
  • Present cars
    2007 Carrera S

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Hello all, been lurking here for awhile, got my first Porsche in October, a 2007 911 Carrera S. Wanted to share this and see if anybody has seen this before. Started my car up the other day and was greeted by discolored pixels in my Central display of the instrument panel. Called a few dealers and no service advisors had heard of the problem before. I am 4 months out of warranty and before taking it to dealer I went ahead and opened a goodwill case with PCNA, took it in for inspection on Thursday at Porsche of Tysons Corner in Virginia. Service consultant said most likely I should expect some level of participation from Porsche with best case being 75% of part. Anyway the claim was denied next day. Not posting here to complain about the denial of goodwill, it is disappointing but I am not the original owner and it is outside the warranty period, but just see if anybody else has had this happen to their cluster.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.