Jump to content

The RennTech.org community is Member supported!  Please consider an ANNUAL donation to help keep this site operating.
Click here to Donate

Welcome to RennTech.org Community, Guest

There are many great features available to you once you register at RennTech.org
You are free to view posts here, but you must log in to reply to existing posts, or to start your own new topic. Like most online communities, there are costs involved to maintain a site like this - so we encourage our members to donate. All donations go to the costs operating and maintaining this site. We prefer that guests take part in our community and we offer a lot in return to those willing to join our corner of the Porsche world. This site is 99 percent member supported (less than 1 percent comes from advertising) - so please consider an annual donation to keep this site running.

Here are some of the features available - once you register at RennTech.org

  • View Classified Ads
  • DIY Tutorials
  • Porsche TSB Listings (limited)
  • VIN Decoder
  • Special Offers
  • OBD II P-Codes
  • Paint Codes
  • Registry
  • Videos System
  • View Reviews
  • and get rid of this welcome message

It takes just a few minutes to register, and it's FREE

Contributing Members also get these additional benefits:
(you become a Contributing Member by donating money to the operation of this site)

  • No ads - advertisements are removed
  • Access the Contributors Only Forum
  • Contributing Members Only Downloads
  • Send attachments with PMs
  • All image/file storage limits are substantially increased for all Contributing Members
  • Option Codes Lookup
  • VIN Option Lookups (limited)

Stephtell

Members
  • Content Count

    52
  • Joined

  • Last visited

Everything posted by Stephtell

  1. Right then, the starting issue seems to have been resolved by connecting the battery to a tricklecharger wich has a 'reconditioning' feature. Car starts up fine now everytime. The other issues remain: I'm guessing atleast one or possibly more servo's have packed up in the climate control system wich I will need to fix because the constant noise is utterly annoying... I would very much like your input so here's hoping I'll get a reply! Will also check the front interiorlight-switch today, doesn't seem to work and I did find lots of postings on that so I'm very happy with the forum already!
  2. Hello, My girlfriend recently bought an '03 Cayenne S and it seems to have some issues...now I have searched this forum but do forgive me if I missed something obvious... 1. Whenever the climate control is set on 'auto' the blower runs on the second highest setting all the time even thougheverything is up to temperature and the glass isn't fogged up or anything...very annoying as it is loud as hell! What can cause this and/or how can it be fixed? 2. Sometimes when you try to start the first turn of the key does not engage the starter even though the dash illuminates. Bad starter/solenoid
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.